summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 00:47:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 00:50:54 +0200
commitd0fa187c736831ecd77f2a2fc22797b3cb46d628 (patch)
tree08ea2687cc05363237fabea1c300ac81629d8b35 /dev-python/path-py
parentdev-python/paste: Remove old (diff)
downloadgentoo-d0fa187c736831ecd77f2a2fc22797b3cb46d628.tar.gz
gentoo-d0fa187c736831ecd77f2a2fc22797b3cb46d628.tar.bz2
gentoo-d0fa187c736831ecd77f2a2fc22797b3cb46d628.zip
dev-python/path-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/files/path-py-12.0.2-py38.patch19
-rw-r--r--dev-python/path-py/path-py-14.0.1.ebuild59
3 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index e5acd2e041ff..d304f27e7487 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,2 +1 @@
-DIST path-14.0.1.tar.gz 73830 BLAKE2B 7528f90708423802dbb177309b1a608bf8dd6b8b1563fcf3904a805830b1c53b76866ec8055bb8d4afda4adb88209b789aed90a33916e450748866479cad1889 SHA512 195abf3e70f3e82566653c8a1154047a8ab82b98eda09a2ae38ba8989e382fd3225fb5c772b827be54a3eafa696829afda2a0198d1bef7ee369e6dc40b0bf11c
DIST path-15.0.0.tar.gz 73642 BLAKE2B 186b77b6571dd878a5b64b575289bb5ee549145ccd0c7b858f99c9e3772cf98f2cc7ff5da759e7fa660296abc49c053a388ad95466c51adccce2162c682c6566 SHA512 e41684c576b959e27258f60c0d8b69719c38a5a7a04d9646089aea91227781573368a08f01230dca831732ae687741d22caf52efd9a481378b8d4e77627fe3a5
diff --git a/dev-python/path-py/files/path-py-12.0.2-py38.patch b/dev-python/path-py/files/path-py-12.0.2-py38.patch
deleted file mode 100644
index 292b0454acc1..000000000000
--- a/dev-python/path-py/files/path-py-12.0.2-py38.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -ur path.py-12.0.2.orig/path/__init__.py path.py-12.0.2/path/__init__.py
---- path.py-12.0.2.orig/path/__init__.py 2019-11-20 17:17:03.644205243 -0800
-+++ path.py-12.0.2/path/__init__.py 2019-11-20 17:17:57.356875924 -0800
-@@ -72,7 +72,13 @@
-
- __version__ = importlib_metadata.version('path.py')
- except Exception:
-- __version__ = 'unknown'
-+ try:
-+ import importlib.metadata
-+
-+ __version__ = importlib.metadata.version('path.py')
-+
-+ except Exception:
-+ __version__ = 'unknown'
-
-
- class TreeWalkWarning(Warning):
-Only in path.py-12.0.2/path: .__init__.py.un~
diff --git a/dev-python/path-py/path-py-14.0.1.ebuild b/dev-python/path-py/path-py-14.0.1.ebuild
deleted file mode 100644
index 13f0dc92d69e..000000000000
--- a/dev-python/path-py/path-py-14.0.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-MY_P="path-${PV}"
-
-DESCRIPTION="A module wrapper for os.path"
-HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
-SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_{5,6,7} pypy3)
- dev-python/appdirs[${PYTHON_USEDEP}]
- !<dev-python/pytest-shutil-1.7.0-r1
- !<dev-python/pytest-virtualenv-1.7.0-r1"
-BDEPEND="
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/path-py-12.0.2-py38.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # avoid a setuptools_scm dependency
- sed -e "s/setup_requires = setuptools_scm/version = '${PV}'/" \
- -i setup.cfg || die
-
- # disable fancy test deps
- sed -e 's: --flake8:: ; s: --black:: ; s: --cov:: ; s: --mypy::' \
- -i pytest.ini || die
-
- # fragile test for import time
- sed -i -e 's:test_import_time:_&:' test_path.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH=. pytest -vv || die
-}