summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-28 04:35:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-28 04:41:30 +0200
commitfb13c210ff15feb21de300a590ef973b068cfa21 (patch)
treeeb0d45edb0f3181a6b3311e810d63f1f04a9a4a5 /dev-python/path-py
parentdev-python/path-py: Bump to 15.0.0 (diff)
downloadgentoo-fb13c210ff15feb21de300a590ef973b068cfa21.tar.gz
gentoo-fb13c210ff15feb21de300a590ef973b068cfa21.tar.bz2
gentoo-fb13c210ff15feb21de300a590ef973b068cfa21.zip
dev-python/path-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/files/path-py-11.5.2-tests.patch15
-rw-r--r--dev-python/path-py/path-py-11.5.2-r1.ebuild60
3 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index cbed46aa7a25..e5acd2e041ff 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,3 +1,2 @@
DIST path-14.0.1.tar.gz 73830 BLAKE2B 7528f90708423802dbb177309b1a608bf8dd6b8b1563fcf3904a805830b1c53b76866ec8055bb8d4afda4adb88209b789aed90a33916e450748866479cad1889 SHA512 195abf3e70f3e82566653c8a1154047a8ab82b98eda09a2ae38ba8989e382fd3225fb5c772b827be54a3eafa696829afda2a0198d1bef7ee369e6dc40b0bf11c
DIST path-15.0.0.tar.gz 73642 BLAKE2B 186b77b6571dd878a5b64b575289bb5ee549145ccd0c7b858f99c9e3772cf98f2cc7ff5da759e7fa660296abc49c053a388ad95466c51adccce2162c682c6566 SHA512 e41684c576b959e27258f60c0d8b69719c38a5a7a04d9646089aea91227781573368a08f01230dca831732ae687741d22caf52efd9a481378b8d4e77627fe3a5
-DIST path.py-11.5.2.tar.gz 43542 BLAKE2B 6b376eebf5b9197c4a2e23ee25c8261c7a8b9428007a626bc0f7d1be71496f4abf7fc6f11cee628432304e6a684bd690d6895f325981c4dd0092bdf3c4a4a4e3 SHA512 8a76ffd7d369adb4c5cbc25f2a52c5cabe899bf59d248d217fc5a086e45438d9dfe6b65b63aa2c89edd7662a793d213662cd6726d15f5ce49dc6bdaf22425865
diff --git a/dev-python/path-py/files/path-py-11.5.2-tests.patch b/dev-python/path-py/files/path-py-11.5.2-tests.patch
deleted file mode 100644
index 4760b20d3cb4..000000000000
--- a/dev-python/path-py/files/path-py-11.5.2-tests.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/test_path.py b/test_path.py
-index 2a7ddb8..cc7a58f 100644
---- a/test_path.py
-+++ b/test_path.py
-@@ -420,6 +420,10 @@ class TestScratchDir:
- platform.system() == 'Windows' and path.PY3,
- reason="Can't write latin characters. See #133",
- )
-+ @pytest.mark.xfail(
-+ path.PY2,
-+ reason="Broken on python 2.7",
-+ )
- def test_listdir_other_encoding(self, tmpdir):
- """
- Some filesystems allow non-character sequences in path names.
diff --git a/dev-python/path-py/path-py-11.5.2-r1.ebuild b/dev-python/path-py/path-py-11.5.2-r1.ebuild
deleted file mode 100644
index cb5c96e68448..000000000000
--- a/dev-python/path-py/path-py-11.5.2-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-MY_P="path.py-${PV}"
-
-DESCRIPTION="A module wrapper for os.path"
-HOMEPAGE="https://pypi.org/project/path.py/ https://github.com/jaraco/path.py"
-SRC_URI="mirror://pypi/p/path.py/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/backports-os[${PYTHON_USEDEP}]' -2)
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_{5,6,7} pypy3)
- dev-python/appdirs[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/path-py-11.5.2-tests.patch"
-)
-
-S="${WORKDIR}/${MY_P}"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # avoid a setuptools_scm dependency
- sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
- sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
- setup.cfg || die
-
- # disable flake8 tests
- sed -i -r 's: --flake8:: ; s: --black:: ; s: --cov::' \
- pytest.ini || die
-
- # fragile test for import time
- sed -i -e 's:test_import_time:_&:' test_path.py || die
-
- # fails on py3.9
- sed -i -e 's:test_version:_&:' test_path.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH=. pytest -v || die
-}