summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-02-25 15:09:37 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-02-25 16:43:02 -0800
commit59f4c38e1c9dc23a4465f8635c52568d3981a9b0 (patch)
treefd9aad3d38176826cdb36458380d353918a15241 /dev-python/pecan/pecan-1.4.0.ebuild
parentdev-python/logutils-0.3.5: Add py39 (diff)
downloadgentoo-59f4c38e1c9dc23a4465f8635c52568d3981a9b0.tar.gz
gentoo-59f4c38e1c9dc23a4465f8635c52568d3981a9b0.tar.bz2
gentoo-59f4c38e1c9dc23a4465f8635c52568d3981a9b0.zip
dev-python/pecan-1.4.0: Version bump, add py39
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pecan/pecan-1.4.0.ebuild')
-rw-r--r--dev-python/pecan/pecan-1.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pecan/pecan-1.4.0.ebuild b/dev-python/pecan/pecan-1.4.0.ebuild
new file mode 100644
index 000000000000..0582e6a2ec9b
--- /dev/null
+++ b/dev-python/pecan/pecan-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.org/project/pecan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest