summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-10 13:04:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-10 13:04:20 +0200
commit81cf1e43f46e08964d7b585fb55479ba2c514307 (patch)
treeec5d4b8262889d3ad8d02f8f11405741bfc526dc /dev-python/pid/pid-2.1.1.ebuild
parentmail-mta/postfix: remove old (diff)
downloadgentoo-81cf1e43f46e08964d7b585fb55479ba2c514307.tar.gz
gentoo-81cf1e43f46e08964d7b585fb55479ba2c514307.tar.bz2
gentoo-81cf1e43f46e08964d7b585fb55479ba2c514307.zip
dev-python/pid: bump to 2.1.1
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/pid/pid-2.1.1.ebuild')
-rw-r--r--dev-python/pid/pid-2.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pid/pid-2.1.1.ebuild b/dev-python/pid/pid-2.1.1.ebuild
new file mode 100644
index 000000000000..3db31ae19aee
--- /dev/null
+++ b/dev-python/pid/pid-2.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.python.org/pypi/pid https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}