summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-28 17:14:02 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-28 17:14:02 +0100
commita66dfece7639a0f23adc4e38b123d8e77812db57 (patch)
tree028707cbb6d9ac7e328d7cb140ebb02f309a9618 /dev-python/plyvel
parentdev-python/plotly: Remove Py2 (diff)
downloadgentoo-a66dfece7639a0f23adc4e38b123d8e77812db57.tar.gz
gentoo-a66dfece7639a0f23adc4e38b123d8e77812db57.tar.bz2
gentoo-a66dfece7639a0f23adc4e38b123d8e77812db57.zip
dev-python/plyvel: Remove Py2
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/plyvel')
-rw-r--r--dev-python/plyvel/plyvel-1.0.5.ebuild8
-rw-r--r--dev-python/plyvel/plyvel-1.1.0.ebuild8
2 files changed, 2 insertions, 14 deletions
diff --git a/dev-python/plyvel/plyvel-1.0.5.ebuild b/dev-python/plyvel/plyvel-1.0.5.ebuild
index 953e10d1c72d..8e5a110b4ae7 100644
--- a/dev-python/plyvel/plyvel-1.0.5.ebuild
+++ b/dev-python/plyvel/plyvel-1.0.5.ebuild
@@ -4,7 +4,7 @@
EAPI=7
# Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{5,6,7} )
inherit distutils-r1
@@ -28,12 +28,6 @@ DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-python_compile() {
- # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_compile_all() {
if use doc; then
sphinx-build doc doc/_build/html || die
diff --git a/dev-python/plyvel/plyvel-1.1.0.ebuild b/dev-python/plyvel/plyvel-1.1.0.ebuild
index e03758e6af93..577a79b89443 100644
--- a/dev-python/plyvel/plyvel-1.1.0.ebuild
+++ b/dev-python/plyvel/plyvel-1.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
# Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{5,6,7} )
inherit distutils-r1
@@ -28,12 +28,6 @@ DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-python_compile() {
- # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_compile_all() {
if use doc; then
sphinx-build doc doc/_build/html || die