summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-10-27 16:50:34 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-10-27 18:26:57 -0700
commitc0462ef2b84eba0afac3c2f7b261ba22e73b0f0b (patch)
tree73ca333b2a597d359775890fdf40f66f6cb3e148 /dev-python/priority/priority-1.2.1.ebuild
parentdev-python/txrequests: Version bump (diff)
downloadgentoo-c0462ef2b84eba0afac3c2f7b261ba22e73b0f0b.tar.gz
gentoo-c0462ef2b84eba0afac3c2f7b261ba22e73b0f0b.tar.bz2
gentoo-c0462ef2b84eba0afac3c2f7b261ba22e73b0f0b.zip
dev-python/priority: Version bump
Package-Manager: portage-2.3.2_p3
Diffstat (limited to 'dev-python/priority/priority-1.2.1.ebuild')
-rw-r--r--dev-python/priority/priority-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/priority/priority-1.2.1.ebuild b/dev-python/priority/priority-1.2.1.ebuild
new file mode 100644
index 000000000000..e7b9d0db577b
--- /dev/null
+++ b/dev-python/priority/priority-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
+HOMEPAGE="http://python-hyper.org/priority https://github.com/python-hyper/priority https://pypi.python.org/pypi/priority"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
+ cd test
+}