summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-10 20:53:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-10 22:10:58 +0100
commit3191f0e0d3592b1c35e396b6652fd5546ffe46e2 (patch)
tree7950957d802e8d84cfcb03015e50c07510741b21 /dev-python/prompt-toolkit
parentdev-python/httpcore: Bump to 1.0.2 (diff)
downloadgentoo-3191f0e0d3592b1c35e396b6652fd5546ffe46e2.tar.gz
gentoo-3191f0e0d3592b1c35e396b6652fd5546ffe46e2.tar.bz2
gentoo-3191f0e0d3592b1c35e396b6652fd5546ffe46e2.zip
dev-python/prompt-toolkit: Bump to 3.0.40
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt-toolkit')
-rw-r--r--dev-python/prompt-toolkit/Manifest1
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.40.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/Manifest b/dev-python/prompt-toolkit/Manifest
index fe9de91e312f..3479c4194466 100644
--- a/dev-python/prompt-toolkit/Manifest
+++ b/dev-python/prompt-toolkit/Manifest
@@ -1 +1,2 @@
DIST prompt_toolkit-3.0.39.tar.gz 423068 BLAKE2B d8673b3a9f4eb57c503e85471c13cefdb4f53fad58145d4198cd0f678d3f2d9d72d22d651b239386d8ade29c1fd155a98e80e4002b00ccbbbeff577636b9aa27 SHA512 6aaa80d515cd9731be1cc0de97f679b9dc22701dfb3e23b5434240aae0cac5eaede08437171a710492ff4041a9d46956cf8ed02750e9a78319eb61223033ba90
+DIST prompt_toolkit-3.0.40.tar.gz 423978 BLAKE2B f48be10f9629c384d1903c0600cb976b89c68039ffc1fdd1eeb0d0846463850197f20d7ab7c5cf834b538b717acf506b53fa502e31d907a20197f94f246c469a SHA512 55e5ad252a8ae51ba6d985dc69a57f1364643d7fcd8c51ca5a928cc6a0ca424a1d4c9afcc5e8988951d03ed32afbc9a93eb1105c2931b0428b1ac8ec22ad53e8
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.40.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.40.ebuild
new file mode 100644
index 000000000000..f79321605a0f
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.40.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest