summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-06-17 17:48:55 +0000
committerMike Gilbert <floppym@gentoo.org>2019-06-18 11:59:06 -0400
commitfa1d55a3632216af5caa1feb5d4a3b7df8eba533 (patch)
tree289a76c476092ae761ca01b7f15e9f51363b07d9 /dev-python/protobuf-python/protobuf-python-3.8.0.ebuild
parentdev-python/protobuf-python: Stabilize 3.7.1 on amd64/x86. (diff)
downloadgentoo-fa1d55a3632216af5caa1feb5d4a3b7df8eba533.tar.gz
gentoo-fa1d55a3632216af5caa1feb5d4a3b7df8eba533.tar.bz2
gentoo-fa1d55a3632216af5caa1feb5d4a3b7df8eba533.zip
dev-python/protobuf-python: Version bump (3.8.0).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-3.8.0.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.8.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-3.8.0.ebuild b/dev-python/protobuf-python/protobuf-python-3.8.0.ebuild
new file mode 100644
index 000000000000..f222111ba2da
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2008-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# True Authors: Arfrever Frehtes Taifersar Arahesis and others
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
+ EGIT_SUBMODULES=()
+fi
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
+fi
+
+LICENSE="BSD"
+SLOT="0/19"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}"
+RDEPEND="${BDEPEND}
+ !<dev-libs/protobuf-3[python(-)]"
+
+S="${WORKDIR}/protobuf-${PV}/python"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
+fi
+
+python_configure_all() {
+ mydistutilsargs=(--cpp_implementation)
+}
+
+python_compile() {
+ python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name "*.pth" -delete || die
+}