summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-24 21:20:34 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-24 21:38:26 -0700
commit0004ad37a9032385a5ff4a10851388166b77aac2 (patch)
tree83efaa9194581c916d47f1848d5f0827396cffce /dev-python/pyatspi/pyatspi-2.36.0.ebuild
parentx11-libs/gtk+extra: Version bump to 3.3.4 (diff)
downloadgentoo-0004ad37a9032385a5ff4a10851388166b77aac2.tar.gz
gentoo-0004ad37a9032385a5ff4a10851388166b77aac2.tar.bz2
gentoo-0004ad37a9032385a5ff4a10851388166b77aac2.zip
dev-python/pyatspi: Version bump to 2.36.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pyatspi/pyatspi-2.36.0.ebuild')
-rw-r--r--dev-python/pyatspi/pyatspi-2.36.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pyatspi/pyatspi-2.36.0.ebuild b/dev-python/pyatspi/pyatspi-2.36.0.ebuild
new file mode 100644
index 000000000000..0b7083708f43
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.36.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python client bindings for D-Bus AT-SPI"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.34[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installing
+
+ docinto examples
+ dodoc examples/*.py
+}