summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-16 07:08:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-16 07:08:02 +0200
commit4443b13a79611899e38d2a2ab54e1d8d60dc925a (patch)
tree438434ddc38dbb4a7645ced0cd388297e26bcb4a /dev-python/pycodestyle
parentdev-python/Nuitka: Bump to 2.3.4 (diff)
downloadgentoo-4443b13a79611899e38d2a2ab54e1d8d60dc925a.tar.gz
gentoo-4443b13a79611899e38d2a2ab54e1d8d60dc925a.tar.bz2
gentoo-4443b13a79611899e38d2a2ab54e1d8d60dc925a.zip
dev-python/pycodestyle: Bump to 2.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest1
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.12.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 9f27fb940fb2..7b228bb3a0b9 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1 +1,2 @@
DIST pycodestyle-2.11.1.gh.tar.gz 79865 BLAKE2B b4d9ab3d50aba87e7194abd6b3b317183932cd9e5331c95b57f498704643bce2f459ca9fa2016cc2544f31fb9cbe3390c083fd651ede10f131bc1d6f5e462f23 SHA512 8e1f302d7e26d56edd924202435caef32369ea13eb4a0fdfb48c06bb5d77fd7a5aef92d470eef3e6fdd9c3b298751a52a83317e9ddf8b2aa7e3fedc75fb5151a
+DIST pycodestyle-2.12.0.gh.tar.gz 80226 BLAKE2B be53b0909182259543bd388945e865cdb383005722afee58977559adb05ce108f764dfc0951a22db79a3abe84d6d5e90a24ee1524c1ad65fe887876c5002400a SHA512 903dd24113c1757826e31564ebac0ac97ad457b84d292f2f1e798df8e68a3847ff6fed0739430d29becc4a52ba4032d873b0212c13d007695df601637b69bdba
diff --git a/dev-python/pycodestyle/pycodestyle-2.12.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.12.0.ebuild
new file mode 100644
index 000000000000..e23f446e7b74
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.12.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="
+ https://pycodestyle.pycqa.org/en/latest/
+ https://github.com/PyCQA/pycodestyle/
+ https://pypi.org/project/pycodestyle/
+"
+# 2.11.0 broke sdist
+# https://github.com/PyCQA/pycodestyle/issues/1183
+SRC_URI="
+ https://github.com/PyCQA/pycodestyle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest