summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-30 20:14:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-30 20:27:42 +0200
commitdfca06f2053bef4a8292b31be3564475f6355acb (patch)
tree8b691314aa82fbb074537788c8d203e7185c08d7 /dev-python/pycodestyle
parentdev-python/pyflakes: Bump to 3.1.0 (diff)
downloadgentoo-dfca06f2053bef4a8292b31be3564475f6355acb.tar.gz
gentoo-dfca06f2053bef4a8292b31be3564475f6355acb.tar.bz2
gentoo-dfca06f2053bef4a8292b31be3564475f6355acb.zip
dev-python/pycodestyle: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest1
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.11.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 501dbebeb8bc..2de76ab496ec 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1 +1,2 @@
DIST pycodestyle-2.10.0.tar.gz 101916 BLAKE2B 1dbf4c2ea9b1c606740fe1e9804b29100056bad25935182b43dd07d694bf3d321d63b17d2e308dc1ffaca1f4e3e46a4e8df3998424adc4e4a1a33862e608e153 SHA512 b0c3ee7ac56942db1e8cb5f3a59c2bd2a44b7467e73b46ab7b6f932603beefbbd29f2760ee49907447af1a5987dc1961f00788b01456bdd0aed7690e2d54446b
+DIST pycodestyle-2.11.0.gh.tar.gz 79772 BLAKE2B 5995cae91a9e1109b697fae840d1dccd4778096dded7357bdbca1a56b06a031fc524f638e91192564f127b2bc52e94c9e80b2437daac5a129db48f99ca701e48 SHA512 fd688544a7fb01a7e3f4f8cb411cf7bc5b6dfc357de616a2ef61944748ad670c239148766b8ea48a3c316396251ed8a8d8937446f400c28e631621a0d16d3cf5
diff --git a/dev-python/pycodestyle/pycodestyle-2.11.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.11.0.ebuild
new file mode 100644
index 000000000000..efb9462cf118
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.11.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="
+ https://pycodestyle.pycqa.org/en/latest/
+ https://github.com/PyCQA/pycodestyle/
+ https://pypi.org/project/pycodestyle/
+"
+# 2.11.0 broke sdist
+# https://github.com/PyCQA/pycodestyle/issues/1183
+SRC_URI="
+ https://github.com/PyCQA/pycodestyle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest