summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-05 20:34:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-05 20:53:00 +0300
commit43b4da32de303b19f63b4ace55d0c0520ea0bc6e (patch)
treebda386df503f6614c5daccf4217524d875e03815 /dev-python/pycson
parentdev-python/pid: enable py3.11 (diff)
downloadgentoo-43b4da32de303b19f63b4ace55d0c0520ea0bc6e.tar.gz
gentoo-43b4da32de303b19f63b4ace55d0c0520ea0bc6e.tar.bz2
gentoo-43b4da32de303b19f63b4ace55d0c0520ea0bc6e.zip
dev-python/pycson: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pycson')
-rw-r--r--dev-python/pycson/pycson-0.8-r3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pycson/pycson-0.8-r3.ebuild b/dev-python/pycson/pycson-0.8-r3.ebuild
new file mode 100644
index 000000000000..4e9f1a65c4d1
--- /dev/null
+++ b/dev-python/pycson/pycson-0.8-r3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A python parser for the Coffeescript Object Notation (CSON)"
+HOMEPAGE="https://github.com/avakar/pycson/"
+SRC_URI="https://github.com/avakar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+RDEPEND="dev-python/speg"
+
+distutils_enable_tests pytest