summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 17:11:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 17:11:31 +0100
commit48c1325043f48bb87cb7106e7e92ebfc6c7cf226 (patch)
tree98b9b9890f4d600d020d1db6d49d244a5da6e95b /dev-python/pycurl-requests/pycurl-requests-0.5.0-r1.ebuild
parentdev-python/pytest-services: Fix pkgcheck warnings (diff)
downloadgentoo-48c1325043f48bb87cb7106e7e92ebfc6c7cf226.tar.gz
gentoo-48c1325043f48bb87cb7106e7e92ebfc6c7cf226.tar.bz2
gentoo-48c1325043f48bb87cb7106e7e92ebfc6c7cf226.zip
dev-python/pycurl-requests: Modernize, PEP 517, fix tests, py3.12
Closes: https://bugs.gentoo.org/888197 Closes: https://bugs.gentoo.org/909937 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycurl-requests/pycurl-requests-0.5.0-r1.ebuild')
-rw-r--r--dev-python/pycurl-requests/pycurl-requests-0.5.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pycurl-requests/pycurl-requests-0.5.0-r1.ebuild b/dev-python/pycurl-requests/pycurl-requests-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..b300c7a49b12
--- /dev/null
+++ b/dev-python/pycurl-requests/pycurl-requests-0.5.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Requests-compatible interface for PycURL"
+HOMEPAGE="
+ https://github.com/dcoles/pycurl-requests/
+ https://pypi.org/project/pycurl-requests/
+"
+SRC_URI="
+ https://github.com/dcoles/pycurl-requests/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network-sandbox
+ pycurl_requests/tests/test_requests.py::test_get_connect_timeout
+ pycurl_requests/tests/test_requests.py::test_get_connect_timeout_urllib3
+ # TODO: different error?
+ pycurl_requests/tests/test_exceptions.py::test_connecterror_refused
+)