summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-15 12:28:52 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-15 12:37:58 -0800
commitf396341ebb7828d4d1ba7ae270186bf6947cb07b (patch)
treef4230848bbd4a228f02b136d4695d5adc43e3c66 /dev-python/pydocstyle
parentsys-devel/gcc: drop unused PATCHES= assignment (diff)
downloadgentoo-f396341ebb7828d4d1ba7ae270186bf6947cb07b.tar.gz
gentoo-f396341ebb7828d4d1ba7ae270186bf6947cb07b.tar.bz2
gentoo-f396341ebb7828d4d1ba7ae270186bf6947cb07b.zip
dev-python/pydocstyle: Rename from dev-python/pep257
Closes: https://bugs.gentoo.org/672948 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest1
-rw-r--r--dev-python/pydocstyle/metadata.xml16
-rw-r--r--dev-python/pydocstyle/pydocstyle-2.1.1.ebuild34
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
new file mode 100644
index 000000000000..4fae544a3761
--- /dev/null
+++ b/dev-python/pydocstyle/Manifest
@@ -0,0 +1 @@
+DIST pydocstyle-2.1.1.tar.gz 55760 BLAKE2B e470b006b5db04c4bed5c3145b14b949980c71d1dd91dbe34d49599063aaf1cb1d0842dfb992e5d471436446455bde2d309ee573826c039540fa99adba3f828b SHA512 f23939e0350094c67565613bab4ddf285dda5a7379e6ac2493953d6e60ab75588143fd374715765d2aa0728e7117d02e91312dbbe5a9cad28aa8e8e7f68e3bc4
diff --git a/dev-python/pydocstyle/metadata.xml b/dev-python/pydocstyle/metadata.xml
new file mode 100644
index 000000000000..6425ffb95a7d
--- /dev/null
+++ b/dev-python/pydocstyle/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Gentoo Python Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">PyCQA/pydocstyle</remote-id>
+ <remote-id type="pypi">pydocstyle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydocstyle/pydocstyle-2.1.1.ebuild b/dev-python/pydocstyle/pydocstyle-2.1.1.ebuild
new file mode 100644
index 000000000000..6f1106d04f61
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://pypi.python.org/pypi/pep257"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}