summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-02 05:11:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-02 05:22:25 +0200
commit36fd2b955ebe9475394443a95b6440a425ef724e (patch)
tree4dad67930475a3ebce193371f11172c1ad179622 /dev-python/pyhcl/pyhcl-0.4.5.ebuild
parentdev-python/GitPython: Bump to 3.1.33 (diff)
downloadgentoo-36fd2b955ebe9475394443a95b6440a425ef724e.tar.gz
gentoo-36fd2b955ebe9475394443a95b6440a425ef724e.tar.bz2
gentoo-36fd2b955ebe9475394443a95b6440a425ef724e.zip
dev-python/pyhcl: Bump to 0.4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyhcl/pyhcl-0.4.5.ebuild')
-rw-r--r--dev-python/pyhcl/pyhcl-0.4.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyhcl/pyhcl-0.4.5.ebuild b/dev-python/pyhcl/pyhcl-0.4.5.ebuild
new file mode 100644
index 000000000000..5607b0797e55
--- /dev/null
+++ b/dev-python/pyhcl/pyhcl-0.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="HCL configuration parser for python"
+HOMEPAGE="
+ https://github.com/virtuald/pyhcl/
+ https://pypi.org/project/pyhcl/
+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/virtuald/pyhcl.git"
+else
+ SRC_URI="
+ https://github.com/virtuald/pyhcl/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ printf '__version__ = "%s"\n' "${PV}" > src/hcl/version.py || die
+ distutils-r1_python_prepare_all
+}