summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-21 04:28:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-21 04:35:05 +0200
commit34aff07725f0d00e588ba340801018b96c621ece (patch)
treeefce10f2d8896a793a94560cfab8a8a0cfadb56e /dev-python/pyicu
parentdev-libs/apache-arrow: Bump to 16.0.0 (diff)
downloadgentoo-34aff07725f0d00e588ba340801018b96c621ece.tar.gz
gentoo-34aff07725f0d00e588ba340801018b96c621ece.tar.bz2
gentoo-34aff07725f0d00e588ba340801018b96c621ece.zip
dev-python/pyicu: Bump to 2.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyicu')
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.13.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index 2577db7630f9..ab0f9b9a3bb6 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1 +1,2 @@
DIST pyicu-v2.12.tar.bz2 195543 BLAKE2B ffee7f0d77495ca490047f6c1f280e47161a9dcebbf5525c8131a3876d10048f154aabfa2be98cd9bbe8e32cea2be86736cf7aa1b0193084b0b7dc36a45b861f SHA512 b182550a9491795699868908615a823e9e35220b6b43ef745a0e34563a133d2c9c2c5c8ae6e221f8c7117d310214828e8110f9e4113fd5cae7e724425de8fe84
+DIST pyicu-v2.13.tar.bz2 196895 BLAKE2B fba4b412eec92b4b108dc151450de0384324f43215a4ca2e502c91954a48b163b1b0cac290e77860288415be7cb86f2e2751e865636723d5c9481bae5a61410f SHA512 65ced1fe3040456fe7f0a37b67a5e3f2f7ed3fdfe3b1cce98b9dbba1e1f79a17df25c8370969087992964708958e2528d878ee913b3133cf1344866bc2444a9e
diff --git a/dev-python/pyicu/pyicu-2.13.ebuild b/dev-python/pyicu/pyicu-2.13.ebuild
new file mode 100644
index 000000000000..945d1e2c0dc1
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/
+"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test
+}