summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-07 20:34:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-07 20:37:46 +0200
commit523a383573c8764fd1693298ebcf1011a67d09c2 (patch)
tree23c35c9320c9dd240d021b3065b24a625263ed01 /dev-python/pylast
parentdev-python/graphviz: Bump to 0.14.2 (diff)
downloadgentoo-523a383573c8764fd1693298ebcf1011a67d09c2.tar.gz
gentoo-523a383573c8764fd1693298ebcf1011a67d09c2.tar.bz2
gentoo-523a383573c8764fd1693298ebcf1011a67d09c2.zip
dev-python/pylast: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-4.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 5f044ed1002e..92f5bf29dd8a 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-3.3.0.tar.gz 40209 BLAKE2B 45725d8424a54ac03b53a6c7fe79febb0038c07ee6c2685d7b66f29933f91fb4ea55818be1d02f8fb1126758acd1d9ce3366e8a7d84fe3082b9b3003a9b948b3 SHA512 8b0c089896d7efb37bdf3a701d150b0f94f386715eb73122a4a7618f5b1a514f9f7577e8c7c84eacb36b18e69aa064220403a578d0544344ab11e87e1b46695a
+DIST pylast-4.0.0.tar.gz 40044 BLAKE2B 89402027494d608bffc4738857d8a7728175cf29a68af259aec1d6ab3755c5e02268bbacac2ff9bd8d8c6490b86ae200aeed59f34c764a4c2f90ea59cb732070 SHA512 093845c718269ed5a0b5223182e60192a71e2fed9270fec453b96b0b2a5488a0c5a8f6386edb42ed183b97cb7ea00397b4491ff72cbf72f9e7d42dc90fae66e7
diff --git a/dev-python/pylast/pylast-4.0.0.ebuild b/dev-python/pylast/pylast-4.0.0.ebuild
new file mode 100644
index 000000000000..8f31add792e1
--- /dev/null
+++ b/dev-python/pylast/pylast-4.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}