summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-21 02:38:45 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-21 02:38:45 -0400
commit702c20499fa316fb9918ba98d11a2f9e993f0378 (patch)
tree3279c3a61108f3df4fac161e6e269cc3ddfa2103 /dev-python/pylast
parentdev-python/llfuse: version bump to 1.3 (diff)
downloadgentoo-702c20499fa316fb9918ba98d11a2f9e993f0378.tar.gz
gentoo-702c20499fa316fb9918ba98d11a2f9e993f0378.tar.bz2
gentoo-702c20499fa316fb9918ba98d11a2f9e993f0378.zip
dev-python/pylast: version bump to 1.9.0
Closes: https://bugs.gentoo.org/631508
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-1.9.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 4db1d616644f..4389890304a9 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,2 +1,3 @@
DIST pylast-1.6.0.tar.gz 41307 SHA256 6bf325ee0fdeb35780554843cf64df99304abb98c5ce2e451c0df7e95e08b42e SHA512 2e47eca2282da8637d5fc79b8fc6784f6f7e9c88975f10e5f162be1445f81dbce0a01c6d7e8ff14162bc3b48a8a4171bf4c81239b17fb08ea5c6b1eaf432f18f WHIRLPOOL f76dbae7326c2b973c8ac1e68e4f31145e449a37d5a342f7ab551cdc737fe529bf9839b05f74d67805bd97aa66f7808a56abea6f57bf0e74390a33d59aa07179
DIST pylast-1.7.0.tar.gz 42433 SHA256 a482a769b6a037e2e9b78433de91a287eaf6aacff60bbb2f4562c3c7ece10430 SHA512 c5f983f651b4d76a004d5521ae3a76d05dc3b424523be365679b7a35f11a5a83894e2bc18365b058b254935fa804575631eacbde4b37d1e2f3d7eb325eeabab4 WHIRLPOOL 04caefd6a7aa11dda40f270587c0a9cfe393c9262411f802a429e5ba893e7320200ba2e8942047f7d583b0e76e4f7edfc2b5671b223c98084287c7a2b255a4b9
+DIST pylast-1.9.0.tar.gz 42584 SHA256 ae1c4105cbe704d9ac10ba57ac4c26bc576cc33978f1b578101b20c6a2360ca4 SHA512 ff3929583d88466738c9a1e964676652717c9f5bd4631f1a0a7855903e77cd394a612b0e2e8fc2f698ac84a34a135f4e940ff7760c2c88bf388ae56fc9c3da65 WHIRLPOOL 701e11a314c60eec50196103c916c107729f5f233d9a00173813f7f33393818a7a4a7b860bdeaec8c680072ca25604acc13d30ace0575623ffa5159da32b14d7
diff --git a/dev-python/pylast/pylast-1.9.0.ebuild b/dev-python/pylast/pylast-1.9.0.ebuild
new file mode 100644
index 000000000000..dce10b85fb36
--- /dev/null
+++ b/dev-python/pylast/pylast-1.9.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+# As the testing requires a last.fm account and online access it is restricted
+RESTRICT="test"