summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-23 15:03:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-23 16:14:22 +0100
commit49a1a65d3d5fd2fd9c8562468c5aa99a5050eb36 (patch)
treea6df3615e7d45b4986e52c0d0d6acabd5d324c12 /dev-python/pylint-venv
parentdev-java/scala-cli-bin: stabilize 0.1.20 for amd64 (diff)
downloadgentoo-49a1a65d3d5fd2fd9c8562468c5aa99a5050eb36.tar.gz
gentoo-49a1a65d3d5fd2fd9c8562468c5aa99a5050eb36.tar.bz2
gentoo-49a1a65d3d5fd2fd9c8562468c5aa99a5050eb36.zip
dev-python/pylint-venv: Fix testing prior to installing
Closes: https://bugs.gentoo.org/895968 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint-venv')
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
index ad1160f14a79..f90bdef4e3a8 100644
--- a/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
+++ b/dev-python/pylint-venv/pylint-venv-3.0.0.ebuild
@@ -39,5 +39,8 @@ src_prepare() {
}
python_test() {
+ # we need to set PYTHONPATH explicitly since the test runs installed
+ # pylint (i.e. starts outside the test venv)
+ local -x PYTHONPATH=${S}:${PYTHONPATH}
bash test/test.sh || die "Test failed with ${EPYTHON}"
}