summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyoembed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyoembed')
-rw-r--r--dev-python/pyoembed/Manifest1
-rw-r--r--dev-python/pyoembed/metadata.xml19
-rw-r--r--dev-python/pyoembed/pyoembed-0.1.1.ebuild36
-rw-r--r--dev-python/pyoembed/pyoembed-9999.ebuild36
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/pyoembed/Manifest b/dev-python/pyoembed/Manifest
new file mode 100644
index 000000000000..37b8a73d14e0
--- /dev/null
+++ b/dev-python/pyoembed/Manifest
@@ -0,0 +1 @@
+DIST pyoembed-0.1.1.tar.gz 12941 SHA256 7a50072d8f0e38e9aa586c24fd693f225ccd78936f55fa35c3fed3fadf1b0e13 SHA512 6ce7ec87082179c0f35dffe67f7ce91b71c40c57ed6bf7bd0ecd2ce654fbd1ab0c6f6469cbfb4e0a8dafc970bf496ffbc57f09838cf575e0becf7527553de63e WHIRLPOOL ae3cf3eaf51ea52a1c4349df97fb628b78172bb2bcedcf8d99993c38c5526755a73a921929f5b137a6a2d69a884a540cf69badc8cfcfd872c697e6eb5909f098
diff --git a/dev-python/pyoembed/metadata.xml b/dev-python/pyoembed/metadata.xml
new file mode 100644
index 000000000000..ec27dbbcbb3d
--- /dev/null
+++ b/dev-python/pyoembed/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Python library for oEmbed that supports auto-discovered and manually included providers.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <remote-id type="pypi">pyoembed</remote-id>
+ <remote-id type="github">rafaelmartins/pyoembed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyoembed/pyoembed-0.1.1.ebuild b/dev-python/pyoembed/pyoembed-0.1.1.ebuild
new file mode 100644
index 000000000000..82bfdebc5ab7
--- /dev/null
+++ b/dev-python/pyoembed/pyoembed-0.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for oEmbed with auto-discovered and manually added providers"
+HOMEPAGE="https://github.com/rafaelmartins/pyoembed"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="git://github.com/rafaelmartins/pyoembed.git
+ https://github.com/rafaelmartins/pyoembed.git"
+ inherit git-r3
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pyoembed/pyoembed-9999.ebuild b/dev-python/pyoembed/pyoembed-9999.ebuild
new file mode 100644
index 000000000000..82bfdebc5ab7
--- /dev/null
+++ b/dev-python/pyoembed/pyoembed-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for oEmbed with auto-discovered and manually added providers"
+HOMEPAGE="https://github.com/rafaelmartins/pyoembed"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=
+ KEYWORDS=
+ EGIT_REPO_URI="git://github.com/rafaelmartins/pyoembed.git
+ https://github.com/rafaelmartins/pyoembed.git"
+ inherit git-r3
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}