summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyopencl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/metadata.xml8
-rw-r--r--dev-python/pyopencl/pyopencl-2014.1.ebuild47
-rw-r--r--dev-python/pyopencl/pyopencl-2015.1.ebuild47
-rw-r--r--dev-python/pyopencl/pyopencl-9999.ebuild49
5 files changed, 153 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
new file mode 100644
index 000000000000..3f25ec0d2a02
--- /dev/null
+++ b/dev-python/pyopencl/Manifest
@@ -0,0 +1,2 @@
+DIST pyopencl-2014.1.tar.gz 1642825 SHA256 7c8df4f22ef49516a1444760dc622a037c83079ff60ff81779e60cb9fc5410e7 SHA512 da3e4e8d95605381d87db482f61fe7030fe244611a3c35d84c88210bcfb3472dc197be721f92e46e6828cc5d0245981ae004331a7c19e7fd8011a0aab593072f WHIRLPOOL e9d3c742c6ef217cf1f223990f852ae5b5ef50b7eae3513955da00f41134d9805e2078c16cd31429e327ea64a7ea16c15c014a749a3a532c3a11e4babdb91202
+DIST pyopencl-2015.1.tar.gz 1652046 SHA256 823b8c5ae438a70de87b3675c3896d04d785261cb0cbd45c01c7dd0fe9d9f6ff SHA512 0236237b1f21283aa2fa7edf86d4c7a275df508e2bdd833ad83d333f3a070b00b125310bfbf8e0fd7308b47d94c565642f87645cc91c8d7020f1e377cdd8bec5 WHIRLPOOL 2b581e4a02c8f5f77085c87c5e8b63ada0b86c58d04e62e665144be00447a9cdd69e8befecc3effe8b6253f3cace2920e8158417c940d08f89ff2985c479753b
diff --git a/dev-python/pyopencl/metadata.xml b/dev-python/pyopencl/metadata.xml
new file mode 100644
index 000000000000..17d2b2bc6c6b
--- /dev/null
+++ b/dev-python/pyopencl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyopencl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyopencl/pyopencl-2014.1.ebuild b/dev-python/pyopencl/pyopencl-2014.1.ebuild
new file mode 100644
index 000000000000..b945d0d31819
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2014.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyopencl/pyopencl-2015.1.ebuild b/dev-python/pyopencl/pyopencl-2015.1.ebuild
new file mode 100644
index 000000000000..8a282ea9a3d6
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2015.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyopencl/pyopencl-9999.ebuild b/dev-python/pyopencl/pyopencl-9999.ebuild
new file mode 100644
index 000000000000..68ac81627161
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 git-2
+
+EGIT_REPO_URI="http://git.tiker.net/trees/pyopencl.git"
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-9999[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}