summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-12-08 15:19:43 +1000
committerMatt Jolly <kangie@gentoo.org>2024-12-08 15:20:44 +1000
commit3e10178ce9e68df839815dc02ba868f06b888e21 (patch)
tree6953527f8f3fd757e671fb6e8bf85f49838f1221 /dev-python/pyqtgraph
parentdev-python/pyqtgraph: add 0.13.7-r1 (diff)
downloadgentoo-3e10178ce9e68df839815dc02ba868f06b888e21.tar.gz
gentoo-3e10178ce9e68df839815dc02ba868f06b888e21.tar.bz2
gentoo-3e10178ce9e68df839815dc02ba868f06b888e21.zip
dev-python/pyqtgraph: drop 0.13.7
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.13.7.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.13.7.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.13.7.ebuild
deleted file mode 100644
index 07fef575086e..000000000000
--- a/dev-python/pyqtgraph/pyqtgraph-0.13.7.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
-HOMEPAGE="
- https://www.pyqtgraph.org/
- https://github.com/pyqtgraph/pyqtgraph/
- https://pypi.org/project/pyqtgraph/
-"
-SRC_URI="
- https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S=${WORKDIR}/${PN}-${P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv ~x86"
-IUSE="opengl svg"
-REQUIRED_USE="test? ( opengl svg )"
-
-RDEPEND="
- >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/pyqt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/pyqt5[testlib,${PYTHON_USEDEP}]
- dev-python/pytest-xvfb[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- if ! use opengl; then
- rm -r pyqtgraph/opengl || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # apparently fragile
- tests/test_reload.py::test_reload
-
- # TODO
- tests/exporters/test_svg.py::test_plotscene
- tests/graphicsItems/test_ROI.py::test_PolyLineROI
-
- # pyside2 is normally skipped if not installed but these two
- # fail if it is installed
- # TODO: this could be due to USE flags, revisit when pyside2
- # gains py3.9
- 'pyqtgraph/examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
- 'pyqtgraph/examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xvfb
-}