summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-03 07:46:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-03 08:08:55 +0200
commitd16b7524e801404c360bde9bfd7914b4624a56fb (patch)
tree47b955920be188b65c08797a83c78c8e25ea3bbb /dev-python/pytest-httpx
parentdev-python/comm: Bump to 0.1.4 (diff)
downloadgentoo-d16b7524e801404c360bde9bfd7914b4624a56fb.tar.gz
gentoo-d16b7524e801404c360bde9bfd7914b4624a56fb.tar.bz2
gentoo-d16b7524e801404c360bde9bfd7914b4624a56fb.zip
dev-python/pytest-httpx: Bump to 0.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index c99b804273d5..26dada22f189 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,2 +1,3 @@
DIST pytest-httpx-0.22.0.gh.tar.gz 24409 BLAKE2B 9db6622e4997ddf0a70c1a0ef835b077640b3ce1d1c19792feda573577fac1ecfba16bcb7ecb8e4c1578b345764d8301aa121335a259dc91a4805173a549bea3 SHA512 fd89ce70113608195eb8fa8e3d7465d9d15b5a300e7c00f3c50417ba9b205081671fbda9591bdb16accb1973da00f5d0bede9e73a3351b0652080d4059c5f6d6
DIST pytest_httpx-0.23.0.tar.gz 28994 BLAKE2B 909fb72d6172fc1a504f1e6ceaf8eb607a5f59fdafc424400567c7ac11ce6d135353be46cd669864b770b5b4dc0403d2c71b3618e733d124cfd86bb88cb76bc5 SHA512 c0ef087bbcc9e214bda19596c11ca38062c8cd14bb10bff36d9faab3ddf326813f30e70dce476b82a9dae72feac3127625920059fd6e64d8b06edf3004a549a6
+DIST pytest_httpx-0.23.1.tar.gz 29462 BLAKE2B aaccef0152a4b7a6340ef322135dcea366df04f349e5d0b4ee9f02a9995485306da4c7854ef4235543b0dcb0228e2f5957790b2b58a0f41bb739849bfdf26cbc SHA512 4490c716c341d782ebf02c29475b7618c0717bbaa736b0a0eefee8a7c8498d3474dd28d487469fe5806ba0018a07b538d2f583406f561c451de6f8a688d57901
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild
new file mode 100644
index 000000000000..336dab68638d
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest