summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-02-22 15:48:21 -0500
committerMike Gilbert <floppym@gentoo.org>2017-02-22 15:50:52 -0500
commit91aecde960dc3bff1c2610fe726d760bf411d21d (patch)
tree9c8a2f225bb9bb011be60d4fd6be823c971d407c /dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
parentapp-crypt/dehydrated: revbump for better system integration (diff)
downloadgentoo-91aecde960dc3bff1c2610fe726d760bf411d21d.tar.gz
gentoo-91aecde960dc3bff1c2610fe726d760bf411d21d.tar.bz2
gentoo-91aecde960dc3bff1c2610fe726d760bf411d21d.zip
dev-python/pytest-pep8: remove invalid entries from MANIFEST.in
Also RDEPEND on setuptools for entry_points support. Bug: https://bugs.gentoo.org/606574#c2
Diffstat (limited to 'dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild')
-rw-r--r--dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild b/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
index dd03d872fb3c..42c5dafebb6c 100644
--- a/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
+++ b/dev-python/pytest-pep8/pytest-pep8-1.0.6.ebuild
@@ -18,12 +18,17 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pep8-1.3[${PYTHON_USEDEP}]
>=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
dev-python/pytest-cache[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/1.0.6-MANIFEST.patch
+)
+
python_test() {
${EPYTHON} test_pep8.py || die
}