summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-26 20:08:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-26 20:08:26 +0100
commitadb5c6aacbdd8b3d9a0dbfa9c1a3e14c06a6588d (patch)
treebcb14dfe53572d8b28d32dcb794e1d75fdb38b8b /dev-python/pytest-salt-factories
parentRevert "kernel-build.eclass: copy module signing key to tempdir in pkg_setup" (diff)
downloadgentoo-adb5c6aacbdd8b3d9a0dbfa9c1a3e14c06a6588d.tar.gz
gentoo-adb5c6aacbdd8b3d9a0dbfa9c1a3e14c06a6588d.tar.bz2
gentoo-adb5c6aacbdd8b3d9a0dbfa9c1a3e14c06a6588d.zip
dev-python/pytest-salt-factories: Fix tests
Premature push, sorry about that. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-salt-factories')
-rw-r--r--dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc28.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc28.ebuild b/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc28.ebuild
index 0d2b31cca6d5..bf71441f4e49 100644
--- a/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc28.ebuild
+++ b/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc28.ebuild
@@ -59,6 +59,7 @@ python_test() {
local EPYTEST_DESELECT=(
tests/integration/factories/daemons/ssh/test_salt_ssh.py::test_salt_ssh
tests/integration/factories/daemons/sshd/test_sshd.py::test_connect
+ tests/scenarios/examples/test_echoext.py::test_echoext
)
local ret tempdir x
@@ -77,7 +78,7 @@ python_test() {
PYTEST_PLUGINS+=,saltfactories.plugins.${x}
done
- nonfatal epytest --no-sys-stats -x
+ nonfatal epytest --no-sys-stats
ret=${?}
rm -rf "${tempdir}" || die