summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 16:18:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 16:41:59 +0200
commit79cab922cd7701de67a6b809f80894fe53b2cb4f (patch)
treeda0cfdb56d31e05beb5e74f495212450814129e4 /dev-python/pytest-tornasync
parentdev-python/debugpy: Enable py3.12 (diff)
downloadgentoo-79cab922cd7701de67a6b809f80894fe53b2cb4f.tar.gz
gentoo-79cab922cd7701de67a6b809f80894fe53b2cb4f.tar.bz2
gentoo-79cab922cd7701de67a6b809f80894fe53b2cb4f.zip
dev-python/pytest-tornasync: PEP517, fix tests, py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-tornasync')
-rw-r--r--dev-python/pytest-tornasync/Manifest1
-rw-r--r--dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-tornasync/Manifest b/dev-python/pytest-tornasync/Manifest
index 591d86f01ace..e6a8a660ad90 100644
--- a/dev-python/pytest-tornasync/Manifest
+++ b/dev-python/pytest-tornasync/Manifest
@@ -1 +1,2 @@
+DIST pytest-tornasync-0.6.0.post2.gh.tar.gz 6157 BLAKE2B 315526ebfe1801ccb10258c0258a83f16efdc28b2b2dcdeece94423a0230506fc08ef176655e35c7aed007fad40501d6a1b0ad20728dfc58faddaad003fb1182 SHA512 fe21bc724b0bcc192f0ca7628302cda0b8122e1b5aedd4f7a0818bc757f45c1d4f76b2aecc35396349df7fc5b43c1278a5a06af44c2b29d8bf1e691164324231
DIST pytest-tornasync-0.6.0.post2.tar.gz 6201 BLAKE2B 6b6a2f941e649fb33373ef39b9d848d68a8af0f5e0d1a5e4496a9160e8e63ea108832437e87382c8203bb2c75673fad37b4ebd76157913199eb1661cd0216591 SHA512 2e258913b17a5442d18928833ee7e9771b6dbd148dbf251a7661432a54d4b9f9f3a7c396134eb544c0e3ce0af48c99d2d632399ac6ebdcf148187a7a523f4974
diff --git a/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild
new file mode 100644
index 000000000000..597b80841a4d
--- /dev/null
+++ b/dev-python/pytest-tornasync/pytest-tornasync-0.6.0_p2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+MY_P=${PN}-${PV/_p/.post}
+DESCRIPTION="Pytest plugin for testing Python 3.5+ Tornado code"
+HOMEPAGE="
+ https://github.com/eukaryote/pytest-tornasync/
+ https://pypi.org/project/pytest-tornasync/
+"
+SRC_URI="
+ https://github.com/eukaryote/pytest-tornasync/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the license file
+ sed -i -e '/LICENSE/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}