summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-15 09:54:35 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-15 09:54:35 +0100
commitf3ba035129f73a0c5a570ca541047dd7fef8cd15 (patch)
tree46b87267016322b35994b67cedbd4e84d660e8a7 /dev-python/python-debian/python-debian-0.1.37.ebuild
parentdev-python/phonenumbers: Remove old (diff)
downloadgentoo-f3ba035129f73a0c5a570ca541047dd7fef8cd15.tar.gz
gentoo-f3ba035129f73a0c5a570ca541047dd7fef8cd15.tar.bz2
gentoo-f3ba035129f73a0c5a570ca541047dd7fef8cd15.zip
dev-python/python-debian: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-debian/python-debian-0.1.37.ebuild')
-rw-r--r--dev-python/python-debian/python-debian-0.1.37.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/python-debian/python-debian-0.1.37.ebuild b/dev-python/python-debian/python-debian-0.1.37.ebuild
deleted file mode 100644
index 86681e27da74..000000000000
--- a/dev-python/python-debian/python-debian-0.1.37.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2011-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python modules to work with Debian-related data formats"
-HOMEPAGE="https://salsa.debian.org/python-debian-team/python-debian"
-SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( app-arch/dpkg )
-"
-
-PATCHES=( "${FILESDIR}/0.1.36-disable-apt-pkg.patch" )
-
-python_compile_all() {
- ${EPYTHON} lib/debian/doc-debtags > README.debtags || die
-}
-
-python_test() {
- ${EPYTHON} -m unittest discover --verbose lib || die "Testing failed with ${EPYTHON}"
-}