summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 18:13:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 18:13:57 +0100
commit74a9eca3d1ce2f89770ecf7b53dcc117da8a1cf0 (patch)
tree830ea824bf8d36aec01c26ab9d881d372b6f86c3 /dev-python/python-discid
parentdev-python/python-ldap: Enable py3.12 (diff)
downloadgentoo-74a9eca3d1ce2f89770ecf7b53dcc117da8a1cf0.tar.gz
gentoo-74a9eca3d1ce2f89770ecf7b53dcc117da8a1cf0.tar.bz2
gentoo-74a9eca3d1ce2f89770ecf7b53dcc117da8a1cf0.zip
dev-python/python-discid: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-discid')
-rw-r--r--dev-python/python-discid/Manifest2
-rw-r--r--dev-python/python-discid/python-discid-1.2.0-r1.ebuild27
2 files changed, 22 insertions, 7 deletions
diff --git a/dev-python/python-discid/Manifest b/dev-python/python-discid/Manifest
index e455554b623c..7bbf1b7d40f7 100644
--- a/dev-python/python-discid/Manifest
+++ b/dev-python/python-discid/Manifest
@@ -1 +1 @@
-DIST python-discid-1.2.0.tar.gz 30756 BLAKE2B 616613de23b66adfc92227a9f36b710649f2a419ffd83443766ebcf1dbfaf528b7d933011bcbdcd19f5092726b81e40d905a62a64262a528dfad89e561210992 SHA512 239cb608508e94109aa9b8b582bc3de1fb9408b508d56698d7f17ec9ebb0d37c1fb76557d98b6d194c1532e3047efcde3adc5d6e9634bc87533d331423a7f19f
+DIST python-discid-1.2.0.gh.tar.gz 30756 BLAKE2B 616613de23b66adfc92227a9f36b710649f2a419ffd83443766ebcf1dbfaf528b7d933011bcbdcd19f5092726b81e40d905a62a64262a528dfad89e561210992 SHA512 239cb608508e94109aa9b8b582bc3de1fb9408b508d56698d7f17ec9ebb0d37c1fb76557d98b6d194c1532e3047efcde3adc5d6e9634bc87533d331423a7f19f
diff --git a/dev-python/python-discid/python-discid-1.2.0-r1.ebuild b/dev-python/python-discid/python-discid-1.2.0-r1.ebuild
index 64e78156abbe..9933139eb3ec 100644
--- a/dev-python/python-discid/python-discid-1.2.0-r1.ebuild
+++ b/dev-python/python-discid/python-discid-1.2.0-r1.ebuild
@@ -4,20 +4,35 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Python bindings for libdiscid"
-HOMEPAGE="https://github.com/JonnyJD/python-discid"
-SRC_URI="https://github.com/JonnyJD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://python-discid.readthedocs.io/en/latest/
+ https://github.com/JonnyJD/python-discid/
+ https://pypi.org/project/discid/
+"
+SRC_URI="
+ https://github.com/JonnyJD/python-discid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc x86"
-RDEPEND=">=media-libs/libdiscid-0.2.2"
-DEPEND="${RDEPEND}"
+DEPEND="
+ >=media-libs/libdiscid-0.2.2
+"
+RDEPEND="
+ ${DEPEND}
+"
distutils_enable_sphinx doc
-distutils_enable_tests setup.py
+
+python_test() {
+ "${EPYTHON}" -m unittest -v test_discid.TestModule{Private,} ||
+ die "Tests failed with ${EPYTHON}"
+}