summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-07 23:06:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-07 23:07:27 +0200
commit4721f288d594b3f2aeb49e91afcc3c17ef8f7308 (patch)
treebd22bd6c579990f99ebe6bbc5138f2e728580ab6 /dev-python/python-docs/python-docs-2.7.18.ebuild
parentmedia-video/ffmpeg: keyworded 4.3-r1 for ia64 (diff)
downloadgentoo-4721f288d594b3f2aeb49e91afcc3c17ef8f7308.tar.gz
gentoo-4721f288d594b3f2aeb49e91afcc3c17ef8f7308.tar.bz2
gentoo-4721f288d594b3f2aeb49e91afcc3c17ef8f7308.zip
dev-python/python-docs: Mass bump to match dev-lang/python
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs/python-docs-2.7.18.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.7.18.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.7.18.ebuild b/dev-python/python-docs/python-docs-2.7.18.ebuild
new file mode 100644
index 000000000000..2804f868635a
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.7.18.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}