summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 20:17:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 20:19:11 +0200
commit607e8929ba8fe99dce92a10dabeb1aa4df0ddb10 (patch)
tree9d6ece399388d942c5ebe3b2e2854d759ac30609 /dev-python/python-docs/python-docs-3.8.5.ebuild
parentdev-python/python-docs: Bump to 3.7.9 (diff)
downloadgentoo-607e8929ba8fe99dce92a10dabeb1aa4df0ddb10.tar.gz
gentoo-607e8929ba8fe99dce92a10dabeb1aa4df0ddb10.tar.bz2
gentoo-607e8929ba8fe99dce92a10dabeb1aa4df0ddb10.zip
dev-python/python-docs: Bump to 3.8.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs/python-docs-3.8.5.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.8.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.8.5.ebuild b/dev-python/python-docs/python-docs-3.8.5.ebuild
new file mode 100644
index 000000000000..2804f868635a
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.8.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}