summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-04 22:39:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-05 22:27:35 +0100
commit52f5856141b35dc1e9dbe8027c73bc1968abfcb6 (patch)
tree4b9051048eae6fde79ac4b0ee2dfe89ace9f2ee0 /dev-python/python-editor
parentdev-python/flask-script: python3_8 (diff)
downloadgentoo-52f5856141b35dc1e9dbe8027c73bc1968abfcb6.tar.gz
gentoo-52f5856141b35dc1e9dbe8027c73bc1968abfcb6.tar.bz2
gentoo-52f5856141b35dc1e9dbe8027c73bc1968abfcb6.zip
dev-python/python-editor: 1.0.4 version bump, python3_8
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/python-editor')
-rw-r--r--dev-python/python-editor/Manifest1
-rw-r--r--dev-python/python-editor/python-editor-1.0.4.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/python-editor/Manifest b/dev-python/python-editor/Manifest
index 97b4eb2d8e4a..27c0e5e3012f 100644
--- a/dev-python/python-editor/Manifest
+++ b/dev-python/python-editor/Manifest
@@ -1 +1,2 @@
DIST python-editor-1.0.3.tar.gz 6975 BLAKE2B 23a4b0990f8715eb0b0ce538f1fbf47d61cf7209588c8be31ae3fb047c706eaf2628c04b29dff517a221676566241f066053680749ab864d067334f875796eba SHA512 258d1ea17ea1c09d8ef52d3b624cc17710559f4a8db3c64696f72aecfcc0830d3509dcdcc9d1ac272155b2aaab432edb7142b0a37f2c3263a2505bff940a3cab
+DIST python-editor-1.0.4.tar.gz 7132 BLAKE2B c955a2e3d2f607133781ef17146b20c13a409def6397e9698a8bc19c5a9f40af002a0f772455fb96e60088a732013ea6c471c198be0ac4c6c881724e762844c2 SHA512 c8ce2403bfe6c93935c7f4c384a8618a39cdaefe1ff5b1ff2cf4562866d8b3caa616e428c0a1634a56db934caeb474e7f84f8d5e009b9ed664189fdece8146f6
diff --git a/dev-python/python-editor/python-editor-1.0.4.ebuild b/dev-python/python-editor/python-editor-1.0.4.ebuild
new file mode 100644
index 000000000000..63553b089a2a
--- /dev/null
+++ b/dev-python/python-editor/python-editor-1.0.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Programmatically open an editor, capture the result."
+HOMEPAGE="https://github.com/fmoo/python-editor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"