summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-05-10 17:19:26 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-05-18 18:14:01 +0300
commit5f15365414462cce163d8a5aa63e2d5aafc63c4b (patch)
tree6cf88f9ebfe5f64dda463ca89792e9e1786e65b0 /dev-python/python-gammu/python-gammu-3.2.4.ebuild
parentapp-mobilephone/gammu: bump to 1.42.0 (diff)
downloadgentoo-5f15365414462cce163d8a5aa63e2d5aafc63c4b.tar.gz
gentoo-5f15365414462cce163d8a5aa63e2d5aafc63c4b.tar.bz2
gentoo-5f15365414462cce163d8a5aa63e2d5aafc63c4b.zip
dev-python/python-gammu: bump to 3.2.4
just bump Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/25424 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/python-gammu/python-gammu-3.2.4.ebuild')
-rw-r--r--dev-python/python-gammu/python-gammu-3.2.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-gammu/python-gammu-3.2.4.ebuild b/dev-python/python-gammu/python-gammu-3.2.4.ebuild
new file mode 100644
index 000000000000..bcad3a30d78f
--- /dev/null
+++ b/dev-python/python-gammu/python-gammu-3.2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Gammu"
+HOMEPAGE="https://wammu.eu/python-gammu/"
+SRC_URI="https://github.com/gammu/python-gammu/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-mobilephone/gammu-1.34.0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(python_gen_impl_dep sqlite)
+ app-mobilephone/gammu[dbi]
+ )"
+
+DOCS=( AUTHORS NEWS.rst README.rst )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docompress -x /usr/share/doc/${P}/examples
+ dodoc -r examples
+ fi
+}