summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-30 03:51:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-30 03:53:49 +0200
commit786e73e4da14050887b74e9e9355c133e815465d (patch)
tree6cb7aa433c5296fd00c56bdd07118bf1bc015388 /dev-python/python-ironicclient/python-ironicclient-5.8.0.ebuild
parentdev-python/jsondiff: Bump to 2.2.1 (diff)
downloadgentoo-786e73e4da14050887b74e9e9355c133e815465d.tar.gz
gentoo-786e73e4da14050887b74e9e9355c133e815465d.tar.bz2
gentoo-786e73e4da14050887b74e9e9355c133e815465d.zip
dev-python/python-ironicclient: Bump to 5.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-ironicclient/python-ironicclient-5.8.0.ebuild')
-rw-r--r--dev-python/python-ironicclient/python-ironicclient-5.8.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-ironicclient/python-ironicclient-5.8.0.ebuild b/dev-python/python-ironicclient/python-ironicclient-5.8.0.ebuild
new file mode 100644
index 000000000000..036a407a0b35
--- /dev/null
+++ b/dev-python/python-ironicclient/python-ironicclient-5.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pbr
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the Ironic API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-ironicclient/
+ https://github.com/openstack/python-ironicclient/
+ https://pypi.org/project/python-ironicclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth1-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tempest-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest