summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-13 00:41:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-13 00:41:42 +0200
commita6e0b0d927aa7eb80b91b62236f3ca6a39a1fd79 (patch)
tree55fa78899814bd7ff56bb8575231346e2c55d16e /dev-python/python-jose
parentdev-python/pytest: Remove old (diff)
downloadgentoo-a6e0b0d927aa7eb80b91b62236f3ca6a39a1fd79.tar.gz
gentoo-a6e0b0d927aa7eb80b91b62236f3ca6a39a1fd79.tar.bz2
gentoo-a6e0b0d927aa7eb80b91b62236f3ca6a39a1fd79.zip
dev-python/python-jose: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-jose')
-rw-r--r--dev-python/python-jose/Manifest1
-rw-r--r--dev-python/python-jose/python-jose-3.2.0-r1.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/python-jose/Manifest b/dev-python/python-jose/Manifest
index 3277af54aaaa..f7b007195709 100644
--- a/dev-python/python-jose/Manifest
+++ b/dev-python/python-jose/Manifest
@@ -1,2 +1 @@
-DIST python-jose-3.2.0.tar.gz 102183 BLAKE2B edc0b0e651ec63333345eb29e0c08649823d8c59e88e2f39127081a04c2afedee0ae1c83709dc45bd81f4143cc0e1e76d22117ea11160ab6418372c69f1b216a SHA512 f81e0284ef2df05a5b2dfc5448f3cce0c8988c4ba5d40f935666ee1693a964db3db62609a38192e317bab6b3945fc5c3122b59f373dbc308363d123ea9752efa
DIST python-jose-3.3.0.tar.gz 126578 BLAKE2B d1279d2a0788b4d395e760ee3a1b2ce8c9340ad12ebe103cb1ba98aea33566cf0134d5af75be9727fff96adab4fc88f1b471ba9ea7d36c16de10587a9efd1304 SHA512 de7147cc6e12406d6e459c32829acae46395acba727c53e65bc05f4794ee3050eecd355e3ae2e87f4ebdbd871f53822eea08a10f25d7ca6088fc6128dc7d9637
diff --git a/dev-python/python-jose/python-jose-3.2.0-r1.ebuild b/dev-python/python-jose/python-jose-3.2.0-r1.ebuild
deleted file mode 100644
index a896c8929b37..000000000000
--- a/dev-python/python-jose/python-jose-3.2.0-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-inherit distutils-r1
-
-DESCRIPTION="A JavaScript Object Signing and Encryption (JOSE) implementation in Python"
-HOMEPAGE="https://github.com/mpdavis/python-jose https://pypi.org/project/python-jose/"
-# pypi tarball lacks unit tests
-SRC_URI="https://github.com/mpdavis/python-jose/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- >=dev-python/pycryptodome-3.3.1[${PYTHON_USEDEP}]
- dev-python/rsa[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_prepare_all() {
- sed -e '/pytest-runner/d' \
- -e '/ecdsa/s:<0.15::' \
- -i setup.py || die
- sed -e '/addopts/d' -i setup.cfg || die
- sed -e 's/sphinxcontrib.napoleon/sphinx.ext.napoleon/' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local deselect=(
- tests/algorithms/test_EC.py::TestECAlgorithm::test_key_too_short
- )
- epytest ${deselect[@]/#/--deselect }
-}