summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-13 20:40:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-13 20:42:03 +0100
commitead94bbf793d2d0fce7b6da473d9a185e0350f17 (patch)
treeef6b7966ff5132e882ef49d6c818f4c598260247 /dev-python/python-stdnum
parentdev-python/libsass: Bump to 0.22.0 (diff)
downloadgentoo-ead94bbf793d2d0fce7b6da473d9a185e0350f17.tar.gz
gentoo-ead94bbf793d2d0fce7b6da473d9a185e0350f17.tar.bz2
gentoo-ead94bbf793d2d0fce7b6da473d9a185e0350f17.zip
dev-python/python-stdnum: Bump to 1.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest1
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.18.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 79b28175de3d..8283f7ca70ed 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1 +1,2 @@
DIST python-stdnum-1.17.tar.gz 1068804 BLAKE2B eaef8d0016f7e836226a6d83d4b54d507477d333af8572f59f24eba44f3a24bedc4d0b7d3492e7a5a64d9ceff77e296bda2876f976aab46cdb27989d0dd80df3 SHA512 9ddec525ea153e3066f205ee70602a59821e793f9ffde66a4b01511daf9a559a3a42082a99bddf69c1159a27b2d9e64d91f8a65ee283a2d7da473d766ce0e711
+DIST python-stdnum-1.18.tar.gz 1138676 BLAKE2B 724afd5d015090023582bc078f278d4107a12d4f126a61eb026b69040654d0890dc0eb0aa197565e844c34f0426f7f0072dac2b8191ba3a15bc87ae7c0b73536 SHA512 ca211fa3f7a0c0a913c5b0c6e32cb477025e203eb4c0a648e47bf95cb361d800d620dc4ebcb3007eefbb5595098486963ffee71ea2c37f84d86443d01131db7c
diff --git a/dev-python/python-stdnum/python-stdnum-1.18.ebuild b/dev-python/python-stdnum/python-stdnum-1.18.ebuild
new file mode 100644
index 000000000000..b1b9d4ecec13
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="
+ https://arthurdejong.org/python-stdnum/
+ https://github.com/arthurdejong/python-stdnum/
+ https://pypi.org/project/python-stdnum/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds-community[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov.*::' setup.cfg || die
+ distutils-r1_src_prepare
+}