summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-10-17 11:50:31 -0400
committerMike Gilbert <floppym@gentoo.org>2016-10-17 11:53:00 -0400
commitac163fe015f6c68e0df72a28bd9ae806cb939dd2 (patch)
tree321bbf025b5f9d08b34ff7fb9f52ae64c6cb6297 /dev-python/python-systemd/python-systemd-233.ebuild
parentwww-client/chromium: use cxx for linking when bootstrapping gn (diff)
downloadgentoo-ac163fe015f6c68e0df72a28bd9ae806cb939dd2.tar.gz
gentoo-ac163fe015f6c68e0df72a28bd9ae806cb939dd2.tar.bz2
gentoo-ac163fe015f6c68e0df72a28bd9ae806cb939dd2.zip
dev-python/python-systemd: bump to 233
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/python-systemd/python-systemd-233.ebuild')
-rw-r--r--dev-python/python-systemd/python-systemd-233.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-systemd/python-systemd-233.ebuild b/dev-python/python-systemd/python-systemd-233.ebuild
new file mode 100644
index 000000000000..b0f7ccf59017
--- /dev/null
+++ b/dev-python/python-systemd/python-systemd-233.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ sys-apps/systemd:0=
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd[python(-)]
+"
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ "${EPYTHON}" -m pytest -v . || die
+ popd > /dev/null || die
+}