summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-09 06:24:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-09 06:24:50 +0100
commit955da4c6a28a9dcd1e959135f1e593964c22ddc7 (patch)
tree3b594fbf139f24e108bec9de655e31e8c3b1455a /dev-python/python-utils
parentdev-python/argh: Bump to 0.27.1 (diff)
downloadgentoo-955da4c6a28a9dcd1e959135f1e593964c22ddc7.tar.gz
gentoo-955da4c6a28a9dcd1e959135f1e593964c22ddc7.tar.bz2
gentoo-955da4c6a28a9dcd1e959135f1e593964c22ddc7.zip
dev-python/python-utils: Bump to 3.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-3.5.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 973d9d99c9d9..1ccb8e45944d 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1 +1,2 @@
DIST python-utils-3.4.5.tar.gz 28608 BLAKE2B c933bf358ad61563fc35bc87329367946a64216afaddb3cd5bff861e0e1fadcc4d18c7a8ff7820bfee5938bc7ede3cea9d450ecc5b7c0825f917c59576d7195c SHA512 35b4b49dfce56e9e530fe979c070889296079d3a1fd548186bf6dbd6fdbce5363818b52a5d7559b7af3bd32561d87639565298386883351168a267fa88e1ff7f
+DIST python-utils-3.5.1.tar.gz 26753 BLAKE2B f6a6f84883671e4e17938bf8a70332766b3e61f77bd86eda976915a5967710c4c8a6bdd295b6ca9d46bed98b30866bbaabd67ac3d4311dfe061fbc3c5a41e4af SHA512 427660db279b438ce30218bea72f96b952f6cd37c99184f04d458814500f056b16ed4f2fa743f94499a996366c162006c771e9523491afb2a7ee0f666ab98718
diff --git a/dev-python/python-utils/python-utils-3.5.1.ebuild b/dev-python/python-utils/python-utils-3.5.1.ebuild
new file mode 100644
index 000000000000..2f51e06e8c85
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}