summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-29 08:36:49 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-29 08:36:49 +0200
commitc84c50215b96376d9dfa5a63a490149200ba14ec (patch)
tree84b1d17e5ca366cb3dc8faa914349a1e82ed7fe8 /dev-python/python3-saml
parentdev-util/rosinstall: enable py3.9, py3.10, cleanup (diff)
downloadgentoo-c84c50215b96376d9dfa5a63a490149200ba14ec.tar.gz
gentoo-c84c50215b96376d9dfa5a63a490149200ba14ec.tar.bz2
gentoo-c84c50215b96376d9dfa5a63a490149200ba14ec.zip
dev-python/python3-saml: add 1.13.0
Closes: https://bugs.gentoo.org/832228 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python3-saml')
-rw-r--r--dev-python/python3-saml/Manifest1
-rw-r--r--dev-python/python3-saml/python3-saml-1.13.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
index 616c9b883df2..b4371a78cfb7 100644
--- a/dev-python/python3-saml/Manifest
+++ b/dev-python/python3-saml/Manifest
@@ -1 +1,2 @@
DIST python3-saml-1.11.0.tar.gz 506373 BLAKE2B 909244e18b6ccb3cd0ed0059e387c14eb75a1a0fb709bdbc33f6dbcdda5b70359e6fedd77ab88e580aaf28503ca3f3fe49308f56338a1d8855149a7ba992034d SHA512 9e54eee28e2b6430d9f08342c312997b6a20f85e3f663573b93c4d8d65a6540c7d6f4e05d35314014b20ba080110a2a51718ac6754ef2b19bfe23d2d4381de24
+DIST python3-saml-1.13.0.gh.tar.gz 509986 BLAKE2B e7c1720683f0391fe943de6ac95c69605a9e1499cf68d9bc416b56390bb5a4f16b17722aad4f6af2cf018195251554ebcc27a10a1605529fd3c98dd37efa4fea SHA512 e13325cdb2857d95ebd34dc4417f7929a76d1afdeb11972ef2fe3719c2db210137c5fef2c5dd4c09bd4dc467aa76afe5cbf14015f7eaf0941b369487313d3c97
diff --git a/dev-python/python3-saml/python3-saml-1.13.0.ebuild b/dev-python/python3-saml/python3-saml-1.13.0.ebuild
new file mode 100644
index 000000000000..eeea40c22257
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="https://github.com/onelogin/python3-saml
+ https://pypi.org/project/python3-saml/"
+SRC_URI="
+ https://github.com/onelogin/python3-saml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/isodate-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmlsec-1.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # unpin deps
+ sed -e 's:==:>=:' -i setup.py || die
+ distutils-r1_src_prepare
+}