summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-19 14:40:25 -0500
committerSam James <sam@gentoo.org>2024-02-19 21:54:38 +0000
commit158e789930eabbefaf87d393a473a6450c7aebd6 (patch)
treed1153967ecd3731df059e163347aa0f1465f5fe8 /dev-python/pythran
parentsci-libs/onnx: always depends on python (diff)
downloadgentoo-158e789930eabbefaf87d393a473a6450c7aebd6.tar.gz
gentoo-158e789930eabbefaf87d393a473a6450c7aebd6.tar.bz2
gentoo-158e789930eabbefaf87d393a473a6450c7aebd6.zip
dev-python/pythran: fix broken runtime metadata
Regression in commit 0c0d0150a89e320b064c09bfa5e6726bbd83a9da. xsimd is a runtime dependency of pythran, by nature of what pythran is and does. It defaults upstream to bundling it, but we remove that and use the system package. When performing that devendoring, it was mistakenly added as a build time dependency (even though xsimd is not used at build time at all!) but not a runtime dependency. This accidentally worked for people who both installed pythran from source instead of using a binhost, and who don't ever use `emerge -c --with-bdeps=n`. But it was very broken. It is also logically used for the testsuite. Revbump but don't drop keywords. It is a purely metadata-only fix and we want that fix out ASAP. Closes: https://bugs.gentoo.org/922782 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/pythran-0.15.0-r1.ebuild (renamed from dev-python/pythran/pythran-0.15.0.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/pythran/pythran-0.15.0.ebuild b/dev-python/pythran/pythran-0.15.0-r1.ebuild
index f7dd12b222d8..8c679fe4ddd9 100644
--- a/dev-python/pythran/pythran-0.15.0.ebuild
+++ b/dev-python/pythran/pythran-0.15.0-r1.ebuild
@@ -27,6 +27,7 @@ KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv ~s390 ~sparc x86"
RDEPEND="
dev-libs/boost
+ dev-cpp/xsimd
=dev-python/beniget-0.4*[${PYTHON_USEDEP}]
=dev-python/gast-0.5*[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
@@ -34,8 +35,10 @@ RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
DEPEND="
- dev-libs/boost
- dev-cpp/xsimd
+ test? (
+ dev-libs/boost
+ dev-cpp/xsimd
+ )
"
BDEPEND="
test? (
@@ -54,7 +57,7 @@ EPYTEST_XDIST=1
distutils_enable_tests pytest
src_configure() {
- # sigh
+ # vendored C++ headers -- use system copies
rm -r pythran/{boost,xsimd} || die
if use test ; then