summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 06:00:52 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:07:46 +0000
commit87e5e4e2dbb72ff665f4a5075574be4034d601d8 (patch)
treebfa7d934d7661c1e6249fd33f6fc45d8bf1cb703 /dev-python/pyxdg
parentdev-python/peewee: bump to 3.14.0 (diff)
downloadgentoo-87e5e4e2dbb72ff665f4a5075574be4034d601d8.tar.gz
gentoo-87e5e4e2dbb72ff665f4a5075574be4034d601d8.tar.bz2
gentoo-87e5e4e2dbb72ff665f4a5075574be4034d601d8.zip
dev-python/pyxdg: bump to 0.27
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyxdg')
-rw-r--r--dev-python/pyxdg/Manifest1
-rw-r--r--dev-python/pyxdg/pyxdg-0.27.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pyxdg/Manifest b/dev-python/pyxdg/Manifest
index 40a65a9d7675..58dc0a82e5ba 100644
--- a/dev-python/pyxdg/Manifest
+++ b/dev-python/pyxdg/Manifest
@@ -1 +1,2 @@
DIST pyxdg-rel-0.26.tar.gz 68435 BLAKE2B a95948db17da9909554e82c0ccf590c3f94ec26d1e34d5ba335868233a649368c08ef30cc19e878310ef038e5bdb6d18cd0e15e9413d9c54b70931f25844ee8c SHA512 0c11bccb74b8c0d98f3c63c318d35d08e1c3bbea128bf7b82792e1bdc0a60c8c4d6414b0612b19296cfb48f7951dfc6dd55ac8d23238e370e7faf6c4f64d1fb6
+DIST pyxdg-rel-0.27.tar.gz 75385 BLAKE2B 44c275ad7f698ffea6963f67bdce46e4faed5c7ae7f6a5aeb03f31dba6358c07263ea826458982cc4f88c0e163c2732f5b498a8d38b5881433e5321cfb181ac6 SHA512 fa3b046ce741574a6c71ef9d1e57752f6c9775431110f6ea38dc851780b5e1f9033eabeb15c67c91bc9bef68bf8f545a25ef856c60e16ab2c4fcbbb053d8341e
diff --git a/dev-python/pyxdg/pyxdg-0.27.ebuild b/dev-python/pyxdg/pyxdg-0.27.ebuild
new file mode 100644
index 000000000000..b348a84228ba
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.27.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-rel-${PV}"
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests nose