summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-20 17:27:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-20 17:27:17 +0100
commit4057aca92eae33167822d0ad11d1c6eb54b13710 (patch)
tree69d0d0c31c407aa81ed3a7a57420c037c0e7c9f9 /dev-python/pyzmq
parentdev-python/dask: Remove old (diff)
downloadgentoo-4057aca92eae33167822d0ad11d1c6eb54b13710.tar.gz
gentoo-4057aca92eae33167822d0ad11d1c6eb54b13710.tar.bz2
gentoo-4057aca92eae33167822d0ad11d1c6eb54b13710.zip
dev-python/pyzmq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-25.1.1.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 3a31b5895105..1e66651c578f 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,2 +1 @@
-DIST pyzmq-25.1.1.gh.tar.gz 389825 BLAKE2B d8e231a0eeaa6a7ad372da912cb42e96e4d862e163859b97d1c369a7940e019c074fc717685f53da06de69cfee79430e343fcd1987d768f3cc99ec75cad0955b SHA512 4aa0d5d5c1036e6ac35898c48d9612f677ee6e9345fafd02091ba81a5081f1ac8bf552eb5c03636ad643cc87e17f037013ec981d9b852c0252d30de8ce046d5a
DIST pyzmq-25.1.2.gh.tar.gz 391272 BLAKE2B 80814704e7ea08d407859c1d71338f6ea283efcd1f3994155334aa5b60c4b6cd89167de8c78d19f8efdbeb5f4071f7b5954ea911eb6e7fbb48a0087b86579cab SHA512 b146a6dbce7cbbe2eb1da7ebd64e463067354f1566cdb4ff634b59bbb6d65e16263b6acb2d101a4ea53f870be5c753c9a12f9cc37bc5a81236681ea4fda6c56b
diff --git a/dev-python/pyzmq/pyzmq-25.1.1.ebuild b/dev-python/pyzmq/pyzmq-25.1.1.ebuild
deleted file mode 100644
index 7a6aa2779167..000000000000
--- a/dev-python/pyzmq/pyzmq-25.1.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="
- https://zeromq.org/languages/python/
- https://pypi.org/project/pyzmq/
- https://github.com/zeromq/pyzmq/
-"
-SRC_URI="
- https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-IUSE="drafts"
-
-# There are additional test failures if zeromq has the draft api enabled, but pyzmq has it disabled.
-DEPEND="
- >=net-libs/zeromq-4.2.2-r2:=[drafts=]
-"
-# It uses cffi backend for pypy, cython backend for cpython
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ' 'python*')
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-23.2.0-libdir.patch
-)
-
-distutils_enable_tests pytest
-# TODO: Package enum_tools
-# distutils_enable_sphinx docs/source \
-# dev-python/numpydoc \
-# dev-python/sphinx-rtd-theme \
-# dev-python/myst-parser
-
-python_prepare_all() {
- export ZMQ_DRAFT_API=$(usex drafts '1' '0')
- export ZMQ_PREFIX="${EPREFIX}/usr"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- zmq/tests/test_auth.py
- zmq/tests/test_cython.py
- zmq/tests/test_zmqstream.py
-
- # swap thrashing on low-mem hosts, per Debian:
- # https://salsa.debian.org/python-team/packages/pyzmq/-/blob/master/debian/patches/skip_large_send
- zmq/tests/test_socket.py::TestSocket::test_large_send
- )
- local EPYTEST_IGNORE=(
- # Avoid dependency on mypy
- zmq/tests/test_mypy.py
- )
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- # not implemented in cffi variant?
- zmq/tests/test_draft.py::TestDraftSockets
- )
- esac
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- epytest -p asyncio -p rerunfailures
-}