summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-27 21:06:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-27 21:09:51 +0100
commitf5b7dd3a762440a3ed5c16ccac73003adb6353ea (patch)
tree352b12c62b373e80ec97ff74103a08b2d0d1aa86 /dev-python/qiskit-aer
parentdev-python/pyupgrade: Remove old (diff)
downloadgentoo-f5b7dd3a762440a3ed5c16ccac73003adb6353ea.tar.gz
gentoo-f5b7dd3a762440a3ed5c16ccac73003adb6353ea.tar.bz2
gentoo-f5b7dd3a762440a3ed5c16ccac73003adb6353ea.zip
dev-python/qiskit-aer: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/qiskit-aer')
-rw-r--r--dev-python/qiskit-aer/Manifest1
-rw-r--r--dev-python/qiskit-aer/qiskit-aer-0.11.1-r2.ebuild105
2 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/qiskit-aer/Manifest b/dev-python/qiskit-aer/Manifest
index 639c3afdf999..03578ff2dbf0 100644
--- a/dev-python/qiskit-aer/Manifest
+++ b/dev-python/qiskit-aer/Manifest
@@ -1,2 +1 @@
-DIST qiskit-aer-0.11.1.gh.tar.gz 6699343 BLAKE2B 3795e1f71914bbc0074a2eac10a82a28f3171d50f292a13dcb705f62daa5fa332a1eabd52391c1b168a822ca6428feb79fe08bb7c93cfd2f7ee5b0d38fed012b SHA512 7880f2ee99f34eca285b9e7cd096981db2f981d41c54881c4036e2745e4af1185b740d93cd157b83ce4adaf8c207c9c063b86e9a1fa514d1388437d6f33e219f
DIST qiskit-aer-0.11.2.gh.tar.gz 6707283 BLAKE2B ae32a469d23a31f202b9f970c59e9efb76c290243bce6179b0a58590d671f6dec0428245131e7cb2966b818dae9fbe7e7078a63fac107572e9e7d4a66e47a539 SHA512 48b28f6c54c898bb3984062ec772373e90899fd436c8e00f0c4abd57b6b98ea6c647283445fe551bd516483b66d25c9861ef519f01a0d1ddc6b3ddbce07bc56a
diff --git a/dev-python/qiskit-aer/qiskit-aer-0.11.1-r2.ebuild b/dev-python/qiskit-aer/qiskit-aer-0.11.1-r2.ebuild
deleted file mode 100644
index 07a04860f30d..000000000000
--- a/dev-python/qiskit-aer/qiskit-aer-0.11.1-r2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="High performance simulator for quantum circuits that includes noise models"
-HOMEPAGE="https://github.com/Qiskit/qiskit-aer"
-SRC_URI="https://github.com/Qiskit/qiskit-aer/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# The reference implementation of BLAS/CBLAS is not compatible with qiskit-aer right now,
-# because importing library causes an error.
-# /usr/lib/python3.9/site-packages/qiskit/providers/aer/backends/controller_wrappers.cpython-39-x86_64-linux-gnu.so: undefined symbol: slamch_
-# Using sci-libs/openblas instead here,
-# with the option to switch between reference/openblas implementation runtime (eselect-ldso).
-COMMON_DEPEND="
- >=dev-python/numpy-1.16.3[${PYTHON_USEDEP}]
- >=dev-cpp/nlohmann_json-3.1.1
- >=dev-libs/spdlog-1.5.0:=
- >=dev-cpp/muParserX-4.0.8
- virtual/cblas[eselect-ldso]
- sci-libs/openblas[eselect-ldso]"
-
-BDEPEND="
- ${COMMON_DEPEND}
- >dev-util/cmake-3.17
- >=dev-python/scikit-build-0.11.0[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/ddt[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="
- ${COMMON_DEPEND}
- >=dev-python/qiskit-terra-0.21.0[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-# Remove cmake dependency from setup.py because of
-# invalid dependency description. We put this dependency check in BDEPEND.
-PATCHES=( "${FILESDIR}/qiskit-aer-0.10.3-remove-cmake-dependency.patch" )
-
-check_openblas() {
- local libdir=$(get_libdir) me="openblas"
-
- # check blas
- local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
- if [[ ${current_blas} != "${me}" ]]; then
- eerror "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- eerror "To use qiskit-aer, you have to issue (as root):"
- eerror "\t eselect blas set ${libdir} ${me}"
- return 1
- fi
- return 0
-}
-
-pkg_setup() {
- if use test; then
- check_openblas
- if [ $? -ne 0 ]; then
- die "Set blas implementation to openblas using 'eselect blas set openblas'!"
- fi
- fi
-}
-
-python_prepare_all() {
- export DISABLE_CONAN="ON"
- export DISABLE_DEPENDENCY_INSTALL="ON"
- #export SKBUILD_CONFIGURE_OPTIONS=""
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # We have to hide the source code directory so tests
- # do not use these, but instead the compiled library.
- mv qiskit_aer qiskit_aer.hidden || die
- epytest -s
- mv qiskit_aer.hidden qiskit_aer || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # Remove bits we don't want installed (bug in scikit-build)
- # bug #858128
- # https://github.com/Qiskit/qiskit-aer/issues/1457
- # https://github.com/Qiskit/qiskit-aer/issues/1574
- # https://github.com/scikit-build/scikit-build/issues/590
- rm -r "${ED}"/usr/{CMakeLists.txt,MANIFEST.in,README.md,cmake,contrib,pyproject.toml,src} || die
-}
-
-pkg_postinst() {
- check_openblas
-}