summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-04 06:02:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-04 06:02:10 +0200
commitc37d5902b5caab5d06b5708862acddce0975352e (patch)
tree52b4372d3d7f266d1a997ab778c6a1294d80e9fd /dev-python/recurring-ical-events
parentdev-python/pytest-jupyter: Bump to 0.10.0 (diff)
downloadgentoo-c37d5902b5caab5d06b5708862acddce0975352e.tar.gz
gentoo-c37d5902b5caab5d06b5708862acddce0975352e.tar.bz2
gentoo-c37d5902b5caab5d06b5708862acddce0975352e.zip
dev-python/recurring-ical-events: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/recurring-ical-events')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.2.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
index e50506d15bb8..5a81b40fea3c 100644
--- a/dev-python/recurring-ical-events/Manifest
+++ b/dev-python/recurring-ical-events/Manifest
@@ -1,2 +1,3 @@
DIST python-recurring-ical-events-2.1.3.gh.tar.gz 329303 BLAKE2B c034fa558629bb8b3c6a901278d14a91826c3dfc805f6960936cd6dc1b219aff027615b05501c85767ab554112f6edf2a2467ced220bd92a7ac493673ca02ffe SHA512 1852b5ed09d1c531ac969aac338893e0409a54d6b0d59e15dbdcbe2a5f97f111c1c01272fa5df640d26c1a12fbc5f284e35c3e10aed0f16a842fe8a6a54462a7
DIST python-recurring-ical-events-2.2.0.gh.tar.gz 332176 BLAKE2B 85eb127e4c8e505f21c135e9241353aee33ae9a5087fb0fb2c2bf9b6a0e913f36a5077569c76c3b92d196e506d8c2be83806a2f8e8554b957a7ee84a1145f316 SHA512 ba5a3b22728d73a392e071d0b1b5363ebf94f25dbe00728fe944d1c7dbb2998b90550756b3ac5e8c51ef310ee269b90f1345ac8380ab8a89bfb7b24f5797ae4c
+DIST python-recurring-ical-events-2.2.1.gh.tar.gz 332458 BLAKE2B 337823e2a98c43015ffd7e848ab4fe43429f787ceb8ff262dca9d73668a785d6245f9e64779c900f1a84a2d7713832621d42044309f38c44bba79fc2853d066f SHA512 1bd6337b5b8670b2c587d54eae26291c381adba76c38e21a937db8a16480d9b4c6eaddda6660fd0c345f67e38ed4f7cfe9e528ecce3686bce9659f4ef30d278c
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.2.1.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.2.1.ebuild
new file mode 100644
index 000000000000..b1d8fa71740b
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/icalendar-6[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-5.0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2023.3[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)