summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-08 09:31:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-08 10:42:14 +0100
commit9058d9d712aca9fcb98df0a643620fed0e2a2dbd (patch)
treea2e167e4a7915df0c14f7e065d40dd3db90e774e /dev-python/redis-py
parentwww-client/firefox-bin: add 97.0 (diff)
downloadgentoo-9058d9d712aca9fcb98df0a643620fed0e2a2dbd.tar.gz
gentoo-9058d9d712aca9fcb98df0a643620fed0e2a2dbd.tar.bz2
gentoo-9058d9d712aca9fcb98df0a643620fed0e2a2dbd.zip
dev-python/redis-py: Bump to 4.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest1
-rw-r--r--dev-python/redis-py/redis-py-4.1.3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index 216f67127eae..ff2d0e2bb226 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1,3 +1,4 @@
DIST redis-py-4.1.0.tar.gz 2346542 BLAKE2B 3d59f904f376df7bca14dcd7bc8547d7a7b41b8d934a50ade6dbf5e74f3da8deef59b3b7cf683fe3c7389859f76fe1d3307f91b52250da945f91b90c629640ab SHA512 85cd09570f4faf34a735befd0677aa8ca2cb0d62b0285c4c040380c2440f2774e47762ec4219381294465343353a15804b96f06b4d6eefa7159a224eb9e72001
DIST redis-py-4.1.1.tar.gz 2349319 BLAKE2B adebda19239e1fd4cf685c0de7a9b2c2fc4e8f23df0e80f2ecdf5f4b9b8b2698fbab613975bd380ea74dc275710d8ed58ee0720486c079bf554612cb7d8b392e SHA512 a974a910dcbaf75516e311badbe6e019cdce668a6d8cd918503934bb92bf97f7ea373fae32139f89a9eecdb360184ae42d24d742ef8b008e95eae648bd992e64
DIST redis-py-4.1.2.tar.gz 2349862 BLAKE2B 3e68918654e63c3403f2408350b2a877027a3c3990b623818332e0e77e1fbaa413e85912ea586a90788a87e0206ebe408ab55df522864dc534907c31a690c0c1 SHA512 beb6e50051eae61e84e7cf37f9f3e3efbc404d49e506b0b3bdae0d0c45fd940f12c801434a6394505519bf327b5933c076ad4f8c66ad812441bc08b3aa682542
+DIST redis-py-4.1.3.tar.gz 2349885 BLAKE2B d1c16a88e7ec70cf2b954fa9cf841f971c02023b7c9387e3e680e16972d546347ee454febf096e54f7bfcd4dabf163e22e1a0ba3186cbb9417cdd7a613d5a992 SHA512 797c1ee4ff4f0e32b52add5bc1cc81fd36cb1eb4d6f9328b38dca46c79a01bc105bc172f56d3bea20d802ee7a6eb934c2ee3ab5f611a49d77f9c4c50d7a4b0d8
diff --git a/dev-python/redis-py/redis-py-4.1.3.ebuild b/dev-python/redis-py/redis-py-4.1.3.ebuild
new file mode 100644
index 000000000000..c0b0dc09baf3
--- /dev/null
+++ b/dev-python/redis-py/redis-py-4.1.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="redis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="https://github.com/redis/redis-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/deprecated[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+
+ # Needs a second Redis running
+ tests/test_commands.py::TestRedisCommands::test_sync
+ tests/test_commands.py::TestRedisCommands::test_psync
+ )
+
+ local EPYTEST_IGNORE=(
+ # SSL tests need Docker/stunnel:
+ # https://github.com/redis/redis-py/commit/18c6809b761bc6755349e1d7e08e74e857ec2c65
+ tests/test_ssl.py
+
+ # Needs multiple Redises running
+ tests/test_cluster.py
+ )
+
+ epytest -k "not redismod and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ # "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}