summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-18 08:27:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-18 08:33:58 +0100
commit1eb3b4a3867b7f659510d7bb55737d6a8dad02e9 (patch)
treeafee0848c3bc247821393dff969628fa0792f508 /dev-python/reedsolomon
parentdev-python/google-api-python-client: Bump to 2.73.0 (diff)
downloadgentoo-1eb3b4a3867b7f659510d7bb55737d6a8dad02e9.tar.gz
gentoo-1eb3b4a3867b7f659510d7bb55737d6a8dad02e9.tar.bz2
gentoo-1eb3b4a3867b7f659510d7bb55737d6a8dad02e9.zip
dev-python/reedsolomon: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reedsolomon')
-rw-r--r--dev-python/reedsolomon/Manifest1
-rw-r--r--dev-python/reedsolomon/reedsolomon-1.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/reedsolomon/Manifest b/dev-python/reedsolomon/Manifest
index 243c59d156ee..472243e1b411 100644
--- a/dev-python/reedsolomon/Manifest
+++ b/dev-python/reedsolomon/Manifest
@@ -1,2 +1,3 @@
DIST reedsolomon-1.6.0.gh.tar.gz 62527 BLAKE2B 100e0152ca8d05605f961dbddcc41552941356a72b488375cb1237cf45938382abf6bfd439b572a9aed11a12068258027fae0bc867e7577280829779d21f53a3 SHA512 ddf73b0bdc78856d9aa76e7bf3fcb9715b9b7f922c2d72dc4bd13a4d5a233844757e2946ef96c545ab7979bc6b62a1f33286711f927871a6689a269d20a81b44
DIST reedsolomon-1.6.1.gh.tar.gz 63944 BLAKE2B 58845e726fdf2096af280bf14feb981d883b2368a47904d33a2386db0fb5d94091ecdc22e48bfa415e2abd9c4b3c99446b3b51bca9cce510961172697a273a0d SHA512 323f91e3e43847023f23087e1038ae240572b87c29ee26be1a05a6ee49824aa86cb706d1856b27e28841fbb14efaf897d1b8e0cb626529fe7cdeaa7fbda6ce27
+DIST reedsolomon-1.7.0.gh.tar.gz 64279 BLAKE2B 304abdf3709dff52c4c515598c511b8e3080475c0755ab68eb9468652f12d2cdb2763bdf88f5fe5e69813928646a8b8378fee9cb2b24d54ce9a6f2b5fb985ac9 SHA512 c7d2ae8444c9e3d6646587f85fe0085a7579cc58d2f4bca3fb89632df4873e2664c81f06ee2e75e928248bb558a7fd8d101a043187ce05e70a079b031981c374
diff --git a/dev-python/reedsolomon/reedsolomon-1.7.0.ebuild b/dev-python/reedsolomon/reedsolomon-1.7.0.ebuild
new file mode 100644
index 000000000000..06ae21367731
--- /dev/null
+++ b/dev-python/reedsolomon/reedsolomon-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Reed Solomon encoder/decoder"
+HOMEPAGE="
+ https://github.com/tomerfiliba/reedsolomon/
+ https://pypi.org/project/reedsolo/
+"
+SRC_URI="
+ https://github.com/tomerfiliba/reedsolomon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Unlicense MIT-0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+src_configure() {
+ DISTUTILS_ARGS=( --cythonize )
+}
+
+python_test() {
+ "${EPYTHON}" tests/test_creedsolo.py || die "creedsolo test failed with ${EPYTHON}"
+ "${EPYTHON}" tests/test_reedsolo.py || die "reedsolo test failed with ${EPYTHON}"
+}