summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-09 05:56:53 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-09 05:56:53 +0100
commitd8087b5ab5f7ae5f369327dc4bed198f8a3ff346 (patch)
tree84fc8693944d55a4ea6c432207627e7a056b52df /dev-python/reedsolomon
parentdev-python/tox: Reenable pypy3 (diff)
downloadgentoo-d8087b5ab5f7ae5f369327dc4bed198f8a3ff346.tar.gz
gentoo-d8087b5ab5f7ae5f369327dc4bed198f8a3ff346.tar.bz2
gentoo-d8087b5ab5f7ae5f369327dc4bed198f8a3ff346.zip
dev-python/reedsolomon: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reedsolomon')
-rw-r--r--dev-python/reedsolomon/Manifest1
-rw-r--r--dev-python/reedsolomon/reedsolomon-1.6.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/reedsolomon/Manifest b/dev-python/reedsolomon/Manifest
index c2cbce4dc1f5..3c352a15bda8 100644
--- a/dev-python/reedsolomon/Manifest
+++ b/dev-python/reedsolomon/Manifest
@@ -1 +1,2 @@
DIST reedsolomon-1.5.4.tar.gz 283778 BLAKE2B 5354b8d320db1533469ae1fd706c0412a81bb408675041af5dbf42b42014e4b779b937fa8e3b3d0a5e67e62d9fd7ce9ac519022dd98dbc82a156ee0cda7914ce SHA512 c738f817c8f536ee86e5bcd3de73a4cf6a3e606ba196a359b6c09e7372dba31316ddb8b134d7c335100e4c2ff0158ff07caa35fee9bc20768bde23cd803e274a
+DIST reedsolomon-1.6.0.gh.tar.gz 62527 BLAKE2B 100e0152ca8d05605f961dbddcc41552941356a72b488375cb1237cf45938382abf6bfd439b572a9aed11a12068258027fae0bc867e7577280829779d21f53a3 SHA512 ddf73b0bdc78856d9aa76e7bf3fcb9715b9b7f922c2d72dc4bd13a4d5a233844757e2946ef96c545ab7979bc6b62a1f33286711f927871a6689a269d20a81b44
diff --git a/dev-python/reedsolomon/reedsolomon-1.6.0.ebuild b/dev-python/reedsolomon/reedsolomon-1.6.0.ebuild
new file mode 100644
index 000000000000..e5e8cdfe1f9c
--- /dev/null
+++ b/dev-python/reedsolomon/reedsolomon-1.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Reed Solomon encoder/decoder"
+HOMEPAGE="
+ https://github.com/tomerfiliba/reedsolomon/
+ https://pypi.org/project/reedsolo/
+"
+SRC_URI="
+ https://github.com/tomerfiliba/reedsolomon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_creedsolo.py || die "creedsolo test failed with ${EPYTHON}"
+ "${EPYTHON}" tests/test_reedsolo.py || die "reedsolo test failed with ${EPYTHON}"
+}