summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-11-25 15:04:31 -0500
committerMike Gilbert <floppym@gentoo.org>2015-11-25 15:05:12 -0500
commitf5a58267ec4f7a941ecef85fdb8e7d402fbccf81 (patch)
tree941723622e2a920224c2cb20747371110eca0dbd /dev-python/reportlab/reportlab-3.1.44-r1.ebuild
parentapp-arch/unace: update to Debian patchset 8 #566018 (diff)
downloadgentoo-f5a58267ec4f7a941ecef85fdb8e7d402fbccf81.tar.gz
gentoo-f5a58267ec4f7a941ecef85fdb8e7d402fbccf81.tar.bz2
gentoo-f5a58267ec4f7a941ecef85fdb8e7d402fbccf81.zip
dev-python/reportlab: Patch-out pip and setuptools from setup.py
Bug: https://bugs.gentoo.org/566750 Package-Manager: portage-2.2.26_p3
Diffstat (limited to 'dev-python/reportlab/reportlab-3.1.44-r1.ebuild')
-rw-r--r--dev-python/reportlab/reportlab-3.1.44-r1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/reportlab/reportlab-3.1.44-r1.ebuild b/dev-python/reportlab/reportlab-3.1.44-r1.ebuild
deleted file mode 100644
index da7f69bed81f..000000000000
--- a/dev-python/reportlab/reportlab-3.1.44-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-# Tests crash with pypy
-
-inherit distutils-r1 flag-o-matic prefix
-
-DESCRIPTION="Tools for generating printable PDF documents from any data source"
-HOMEPAGE="http://www.reportlab.com/"
-SRC_URI="
- mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
- http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/pillow-2.4.0[tiff,${PYTHON_USEDEP}]
- media-fonts/dejavu
- media-libs/libart_lgpl
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-2.2[${PYTHON_USEDEP}]
- app-arch/unzip
-"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${P}/src/reportlab/fonts || die
- unpack pfbfer-20070710.zip
-}
-
-python_prepare_all() {
- sed -i \
- -e "s|/usr/lib/X11/fonts/TrueType/|${EPREFIX}/usr/share/fonts/dejavu/|" \
- -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
- -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
- src/reportlab/rl_config.py || die
-
- eprefixify setup.py
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd tests > /dev/null || die
- "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( demos/. tools/pythonpoint/demos )
-
- distutils-r1_python_install_all
-}