summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-14 09:34:10 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-14 09:34:10 -0500
commitf43d3621972f3aa41edd3496ff0cef6129e52951 (patch)
treebd6cd6a5cc638b018e02977267c60c2194705528 /dev-python/resolvelib
parentdev-libs/leatherman: switch to cmake from cmake-utils (diff)
downloadgentoo-f43d3621972f3aa41edd3496ff0cef6129e52951.tar.gz
gentoo-f43d3621972f3aa41edd3496ff0cef6129e52951.tar.bz2
gentoo-f43d3621972f3aa41edd3496ff0cef6129e52951.zip
dev-python/resolvelib: add for ansible
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/resolvelib')
-rw-r--r--dev-python/resolvelib/Manifest1
-rw-r--r--dev-python/resolvelib/metadata.xml19
-rw-r--r--dev-python/resolvelib/resolvelib-0.7.0.ebuild20
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/resolvelib/Manifest b/dev-python/resolvelib/Manifest
new file mode 100644
index 000000000000..674421461a1a
--- /dev/null
+++ b/dev-python/resolvelib/Manifest
@@ -0,0 +1 @@
+DIST resolvelib-0.7.0.tar.gz 16439 BLAKE2B 5e48f3b5618b84498ec5646e4ef502c9cf1ba6ec720ea450064983d26c8890a6399839261f92a471bb5f235c6c7d976bd7a1c0e2ccc29ba51c0fdb740ce607a6 SHA512 4cfc4ca58c3308209b4fc5c96e8e379a3ec897943493478cdd5b63a6edc21c7c416877eb3ce12954be98131e5f37a9727d753347414790c625284a8e9dc393ea
diff --git a/dev-python/resolvelib/metadata.xml b/dev-python/resolvelib/metadata.xml
new file mode 100644
index 000000000000..f7e853ec0571
--- /dev/null
+++ b/dev-python/resolvelib/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">resolvelib</remote-id>
+ <remote-id type="github">sarugaku/resolvelib</remote-id>
+ <bugs-to>https://github.com/sarugaku/resolvelib/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ResolveLib at the highest level provides a Resolver class that includes
+dependency resolution logic. You give it some things, and a little
+information on how it should interact with them, and it will spit out
+a resolution result.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/resolvelib/resolvelib-0.7.0.ebuild b/dev-python/resolvelib/resolvelib-0.7.0.ebuild
new file mode 100644
index 000000000000..2535428a3c16
--- /dev/null
+++ b/dev-python/resolvelib/resolvelib-0.7.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="provides a Resolver class that includes dependency resolution logic"
+HOMEPAGE="https://github.com/sarugaku/resolvelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""