summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-08 08:39:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-08 10:51:55 +0200
commit0d2913d342385038d1d2d614a9e8f09ded8671b6 (patch)
treec331312c7cdabd06dbbb06093b7c32998e677e09 /dev-python/rfc3986
parentdev-python/rfc3986: Enable python3.10 (diff)
downloadgentoo-0d2913d342385038d1d2d614a9e8f09ded8671b6.tar.gz
gentoo-0d2913d342385038d1d2d614a9e8f09ded8671b6.tar.bz2
gentoo-0d2913d342385038d1d2d614a9e8f09ded8671b6.zip
dev-python/rfc3986: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/Manifest1
-rw-r--r--dev-python/rfc3986/rfc3986-1.5.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
index 9c7607428a46..5b41cd32da64 100644
--- a/dev-python/rfc3986/Manifest
+++ b/dev-python/rfc3986/Manifest
@@ -1 +1,2 @@
DIST rfc3986-1.4.0.tar.gz 44912 BLAKE2B 595a644f8f92823ad31113ce88218cb30d16b37ec7303c0d8e89d2d2b1e18448d99003e95d61dcf09cb64aae517037bae798d1e89c74b652d517a648e80856e8 SHA512 dbcddc09331b794eafed8c2d7b81b7b632ba5cae2741e33ad12e781bc923427a05febd2f2715d037f35769b18c8d790546dfd4bbebe6e71d35777745e446888b
+DIST rfc3986-1.5.0.tar.gz 49378 BLAKE2B f5ef923626fdcbe4d13729a5599012a8a93d234eef7f9ac9dc61620320062a69646f810a8f0ea04f371b9c423850982685e68201f08ba96ad9ead3ab11a9b40d SHA512 b291b88b6890f8c9fcfc353e05d1b8c0435be62f22768568ecf714af083b3c51d7a9b301fc9196d37ad4e6eeb8c6a237ba40914098e755b4ccdf36b7df7906c2
diff --git a/dev-python/rfc3986/rfc3986-1.5.0.ebuild b/dev-python/rfc3986/rfc3986-1.5.0.ebuild
new file mode 100644
index 000000000000..0ce7eca0ae96
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-1.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/python-hyper/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="idna"
+
+RDEPEND="
+ idna? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest