summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 07:13:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 08:04:30 +0200
commit233addade4782b56a75c3786f279c60f74e2f6ab (patch)
tree8ff682744d7ad3cd6ca037a4bba7de86a8b7f54f /dev-python/rich
parentapp-i18n/transifex-client: add new version 1.6.7 (diff)
downloadgentoo-233addade4782b56a75c3786f279c60f74e2f6ab.tar.gz
gentoo-233addade4782b56a75c3786f279c60f74e2f6ab.tar.bz2
gentoo-233addade4782b56a75c3786f279c60f74e2f6ab.zip
dev-python/rich: Bump to 13.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-13.3.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 5334fd98ed7e..5e6bbf371871 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1 +1,2 @@
DIST rich-13.3.3.gh.tar.gz 15060927 BLAKE2B 2d4aaca6dd18b7f3dd6267b3ead09ece8e2edc2ed050c137a93618915f6cd999744957d6925da90446a5b3a46ef871561145d5c2c27ff2722afac24090cf1064 SHA512 049b5145685509f722d744e5b7e2703bf14e5449da02f24e92ac856552bddeef96777760ead4e1e0f6599cc1b13cc424dc558a20c426dcbd7d4230322226832c
+DIST rich-13.3.4.gh.tar.gz 15059899 BLAKE2B f0ca78bf4cdec19136f9372e541ea90713e55acf4dc6f709b8edba9c8dc56da9ac534c6f32b05b634a970e4c02b1f08bfcb5ff949889d6f7bfaa104a1ca6b1cd SHA512 ab3b2ef30ede12f0959671baeff299621303e09750c245b3b3d7b8f1dbd3b7465410400b39668791de57d6027fe24a0a17d5b7284eea162d819c4cb6b9535f81
diff --git a/dev-python/rich/rich-13.3.4.ebuild b/dev-python/rich/rich-13.3.4.ebuild
new file mode 100644
index 000000000000..dcd6ae234066
--- /dev/null
+++ b/dev-python/rich/rich-13.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ <dev-python/markdown-it-py-3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}